aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netsupport.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-01-24 20:02:09 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-01-24 20:02:09 +0000
commitae62798e994a3565b8a1f9e98b40bf33123813fc (patch)
tree86c0693badcb7555cddeb4efc4c5d2ecafe331a8 /package/kernel/linux/modules/netsupport.mk
parentcac0cf6daa5df1faed5bc0f7fc764506e93bace0 (diff)
downloadmaster-187ad058-ae62798e994a3565b8a1f9e98b40bf33123813fc.tar.gz
master-187ad058-ae62798e994a3565b8a1f9e98b40bf33123813fc.tar.bz2
master-187ad058-ae62798e994a3565b8a1f9e98b40bf33123813fc.zip
build: drop obsolete kernel version dependencies
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44110 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/netsupport.mk')
-rw-r--r--package/kernel/linux/modules/netsupport.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 8671df1318..badd54231b 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -251,7 +251,7 @@ $(eval $(call KernelPackage,ipip))
IPSEC-m:= \
- $(if $(CONFIG_LINUX_3_3),,xfrm/xfrm_algo) \
+ xfrm/xfrm_algo \
xfrm/xfrm_ipcomp \
xfrm/xfrm_user \
key/af_key \
@@ -484,7 +484,7 @@ $(eval $(call KernelPackage,gre))
define KernelPackage/gre6
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=GRE support over IPV6
- DEPENDS:=+kmod-ipv6 +kmod-iptunnel +kmod-ip6-tunnel @!LINUX_3_3 @!LINUX_3_6
+ DEPENDS:=+kmod-ipv6 +kmod-iptunnel +kmod-ip6-tunnel
KCONFIG:=CONFIG_IPV6_GRE
FILES:=$(LINUX_DIR)/net/ipv6/ip6_gre.ko
AUTOLOAD:=$(call AutoLoad,39,ip6_gre)