aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netsupport.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-04-11 10:43:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-04-11 10:43:46 +0000
commita2b45c4a8375070c1eaa2d4c30e89d2d56a29b1a (patch)
tree52d06032c07770d04c1e55e839aaeb7f10cf4001 /package/kernel/linux/modules/netsupport.mk
parent2b0dd36cddc7ae4a59cb5661b054d56e590727f0 (diff)
downloadmaster-187ad058-a2b45c4a8375070c1eaa2d4c30e89d2d56a29b1a.tar.gz
master-187ad058-a2b45c4a8375070c1eaa2d4c30e89d2d56a29b1a.tar.bz2
master-187ad058-a2b45c4a8375070c1eaa2d4c30e89d2d56a29b1a.zip
kernel: remove kernel module checks/dependencies for 3.14
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45377 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/netsupport.mk')
-rw-r--r--package/kernel/linux/modules/netsupport.mk10
1 files changed, 4 insertions, 6 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 60e3094c20..547e429f09 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -148,7 +148,6 @@ $(eval $(call KernelPackage,8021q))
define KernelPackage/udptunnel4
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=IPv4 UDP tunneling support
- DEPENDS:=@!LINUX_3_14
KCONFIG:=CONFIG_NET_UDP_TUNNEL
FILES:=$(LINUX_DIR)/net/ipv4/udp_tunnel.ko
AUTOLOAD:=$(call AutoLoad,32,udp_tunnel)
@@ -160,7 +159,6 @@ $(eval $(call KernelPackage,udptunnel4))
define KernelPackage/udptunnel6
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=IPv6 UDP tunneling support
- DEPENDS:=@!LINUX_3_14
KCONFIG:=CONFIG_NET_UDP_TUNNEL
FILES:=$(LINUX_DIR)/net/ipv6/ip6_udp_tunnel.ko
AUTOLOAD:=$(call AutoLoad,32,ip6_udp_tunnel)
@@ -174,8 +172,8 @@ define KernelPackage/vxlan
TITLE:=Native VXLAN Kernel support
DEPENDS:= \
+kmod-iptunnel \
- +!LINUX_3_14:kmod-udptunnel4 \
- +(!LINUX_3_14&&IPV6):kmod-udptunnel6
+ +kmod-udptunnel4 \
+ +IPV6:kmod-udptunnel6
KCONFIG:=CONFIG_VXLAN
FILES:=$(LINUX_DIR)/drivers/net/vxlan.ko
AUTOLOAD:=$(call AutoLoad,13,vxlan)
@@ -863,8 +861,8 @@ define KernelPackage/l2tp
TITLE:=Layer Two Tunneling Protocol (L2TP)
DEPENDS:= \
+IPV6:kmod-ipv6 \
- +!LINUX_3_14:kmod-udptunnel4 \
- +(!LINUX_3_14&&IPV6):kmod-udptunnel6
+ +kmod-udptunnel4 \
+ +IPV6:kmod-udptunnel6
KCONFIG:=CONFIG_L2TP \
CONFIG_L2TP_V3=y \
CONFIG_L2TP_DEBUGFS=n