aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netsupport.mk
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2015-06-04 05:44:44 +0000
committerSteven Barth <steven@midlink.org>2015-06-04 05:44:44 +0000
commit7ec4092a0cdd64d87a088011b8910084c770bde6 (patch)
tree536812e514c72f3059d3d1ebe8db91983726d35e /package/kernel/linux/modules/netsupport.mk
parent722c9b412ef072f10ef69a212485dcd92288583d (diff)
downloadmaster-187ad058-7ec4092a0cdd64d87a088011b8910084c770bde6.tar.gz
master-187ad058-7ec4092a0cdd64d87a088011b8910084c770bde6.tar.bz2
master-187ad058-7ec4092a0cdd64d87a088011b8910084c770bde6.zip
Add sch_fq and sch_pie to the kmod-sched package.
These are two new packet schedulers introduced in Linux 3.12 and 3.14 respectively. sch_fq is a perfect fairness queueing scheduler that also adds pacing on host TCP flows, and sch_pie is an AQM. Having them available in kmod-sched makes it easier for people to test these new queueing schemes. Signed-off-by: Toke Høiland-Jørgensen <toke@toke.dk> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45885 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/netsupport.mk')
-rw-r--r--package/kernel/linux/modules/netsupport.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 4483581bf4..adfdace360 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -802,6 +802,8 @@ define KernelPackage/sched
CONFIG_NET_SCH_TBF \
CONFIG_NET_SCH_SFQ \
CONFIG_NET_SCH_TEQL \
+ CONFIG_NET_SCH_FQ \
+ CONFIG_NET_SCH_PIE \
CONFIG_NET_CLS_BASIC \
CONFIG_NET_ACT_POLICE \
CONFIG_NET_ACT_IPT \