aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netsupport.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-09-17 21:45:17 +0000
committerJohn Crispin <blogic@openwrt.org>2013-09-17 21:45:17 +0000
commit751f92881546b07452e922ad15be9d446f23f592 (patch)
tree2659076169733540dabefd531b086be6ce69f345 /package/kernel/linux/modules/netsupport.mk
parenta1d883cc85daebe3acdcbb5e61183db57040d02a (diff)
downloadmaster-187ad058-751f92881546b07452e922ad15be9d446f23f592.tar.gz
master-187ad058-751f92881546b07452e922ad15be9d446f23f592.tar.bz2
master-187ad058-751f92881546b07452e922ad15be9d446f23f592.zip
kernel: make most modules use AutoProbe
now that we have modprobe we can set more than half of the modules to AutoProbe Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38021 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/netsupport.mk')
-rw-r--r--package/kernel/linux/modules/netsupport.mk13
1 files changed, 5 insertions, 8 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index da84ab8dc3..b9e7740d85 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -521,7 +521,6 @@ define KernelPackage/slhc
DEPENDS:=+kmod-lib-crc-ccitt
KCONFIG:=CONFIG_SLHC
FILES:=$(LINUX_DIR)/drivers/net/slip/slhc.ko
- AUTOLOAD:=$(call AutoLoad,29,slhc)
endef
$(eval $(call KernelPackage,slhc))
@@ -537,7 +536,6 @@ define KernelPackage/ppp
FILES:= \
$(LINUX_DIR)/drivers/net/ppp/ppp_async.ko \
$(LINUX_DIR)/drivers/net/ppp/ppp_generic.ko
- AUTOLOAD:=$(call AutoLoad,30,ppp_generic ppp_async)
endef
define KernelPackage/ppp/description
@@ -569,7 +567,6 @@ define KernelPackage/pppox
DEPENDS:=kmod-ppp
KCONFIG:=CONFIG_PPPOE
FILES:=$(LINUX_DIR)/drivers/net/ppp/pppox.ko
- AUTOLOAD:=$(call AutoLoad,40,pppox)
endef
define KernelPackage/pppox/description
@@ -585,7 +582,7 @@ define KernelPackage/pppoe
DEPENDS:=kmod-ppp +kmod-pppox
KCONFIG:=CONFIG_PPPOE
FILES:=$(LINUX_DIR)/drivers/net/ppp/pppoe.ko
- AUTOLOAD:=$(call AutoLoad,41,pppoe)
+ AUTOLOAD:=$(call AutoProbe,pppoe)
endef
define KernelPackage/pppoe/description
@@ -617,7 +614,7 @@ define KernelPackage/pptp
DEPENDS:=kmod-ppp +kmod-gre +kmod-pppox
KCONFIG:=CONFIG_PPTP
FILES:=$(LINUX_DIR)/drivers/net/ppp/pptp.ko
- AUTOLOAD:=$(call AutoLoad,41,pptp)
+ AUTOLOAD:=$(call AutoProbe,pptp)
endef
$(eval $(call KernelPackage,pptp))
@@ -629,7 +626,7 @@ define KernelPackage/pppol2tp
DEPENDS:=kmod-ppp +kmod-pppox +kmod-l2tp
KCONFIG:=CONFIG_PPPOL2TP
FILES:=$(LINUX_DIR)/net/l2tp/l2tp_ppp.ko
- AUTOLOAD:=$(call AutoLoad,41,l2tp_ppp)
+ AUTOLOAD:=$(call AutoProbe,l2tp_ppp)
endef
define KernelPackage/pppol2tp/description
@@ -645,7 +642,7 @@ define KernelPackage/ipoa
DEPENDS:=kmod-atm
KCONFIG:=CONFIG_ATM_CLIP
FILES:=$(LINUX_DIR)/net/atm/clip.ko
- AUTOLOAD:=$(call AutoLoad,40,clip)
+ AUTOLOAD:=$(call AutoProbe,clip)
endef
define KernelPackage/ipoa/description
@@ -663,7 +660,7 @@ define KernelPackage/mppe
CONFIG_PPP_MPPE_MPPC \
CONFIG_PPP_MPPE
FILES:=$(LINUX_DIR)/drivers/net/ppp/ppp_mppe.ko
- AUTOLOAD:=$(call AutoLoad,31,ppp_mppe)
+ AUTOLOAD:=$(call AutoProbe,ppp_mppe)
endef
define KernelPackage/mppe/description