aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netsupport.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2013-08-04 09:51:07 +0000
committerHauke Mehrtens <hauke@openwrt.org>2013-08-04 09:51:07 +0000
commit69a742c7fc5e2738885614257c30923050a98767 (patch)
tree43f109f74d6cf30b21a37080bc98d7beb6711cd2 /package/kernel/linux/modules/netsupport.mk
parenta558d35af267a08f1098ebb41b1c28a7971c1943 (diff)
downloadmaster-187ad058-69a742c7fc5e2738885614257c30923050a98767.tar.gz
master-187ad058-69a742c7fc5e2738885614257c30923050a98767.tar.bz2
master-187ad058-69a742c7fc5e2738885614257c30923050a98767.zip
kernel: kmod-appletalk: fix dependencies
When CONFIG_LLC gets build as a module, also p8022.ko and psnap.ko are getting build as a module. kmod-appletalk depends on llc.ko and psnap.ko, but at least psnap.ko,was not packed. On most systems CONFIG_LLC will be build into the kernel so this problem does not show up. This fixes the missing dependency of kmod-appletalk on psnap.ko Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37673 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/netsupport.mk')
-rw-r--r--package/kernel/linux/modules/netsupport.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index cf31f28342..da84ab8dc3 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -45,6 +45,7 @@ $(eval $(call KernelPackage,atmtcp))
define KernelPackage/appletalk
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=Appletalk protocol support
+ DEPENDS:=+PACKAGE_kmod-llc:kmod-llc
KCONFIG:= \
CONFIG_ATALK \
CONFIG_DEV_APPLETALK \
@@ -100,8 +101,11 @@ define KernelPackage/llc
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=ANSI/IEEE 802.2 LLC support
KCONFIG:=CONFIG_LLC
- FILES:=$(LINUX_DIR)/net/llc/llc.ko
- AUTOLOAD:=$(call AutoLoad,09,llc)
+ FILES:= \
+ $(LINUX_DIR)/net/llc/llc.ko \
+ $(LINUX_DIR)/net/802/p8022.ko \
+ $(LINUX_DIR)/net/802/psnap.ko
+ AUTOLOAD:=$(call AutoLoad,09,llc p8022 psnap)
endef
define KernelPackage/llc/description