aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netsupport.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-29 08:12:23 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-29 08:12:23 +0000
commit4b86893200de6f1aa9d76578de43c8aa9f5de132 (patch)
tree451d3633f3f234d251d93f861e6a4bda8e005897 /package/kernel/linux/modules/netsupport.mk
parentbdf3aed1173c631822eed37b28ea240c6017c6b4 (diff)
downloadmaster-187ad058-4b86893200de6f1aa9d76578de43c8aa9f5de132.tar.gz
master-187ad058-4b86893200de6f1aa9d76578de43c8aa9f5de132.tar.bz2
master-187ad058-4b86893200de6f1aa9d76578de43c8aa9f5de132.zip
kernel: remove useless AddDepends/crc16 abstraction
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45133 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/netsupport.mk')
-rw-r--r--package/kernel/linux/modules/netsupport.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 4ac23c660c..0d70a88a05 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -825,6 +825,7 @@ $(eval $(call KernelPackage,sched))
define KernelPackage/ax25
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=AX25 support
+ DEPENDS:=+kmod-lib-crc16
KCONFIG:= \
CONFIG_HAMRADIO=y \
CONFIG_AX25 \
@@ -833,7 +834,6 @@ define KernelPackage/ax25
$(LINUX_DIR)/net/ax25/ax25.ko \
$(LINUX_DIR)/drivers/net/hamradio/mkiss.ko
AUTOLOAD:=$(call AutoLoad,80,ax25 mkiss)
- $(call AddDepends/crc16)
endef
define KernelPackage/ax25/description