aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netsupport.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-29 05:15:58 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-29 05:15:58 +0000
commit01afac641e03c5ebb9bde36148d4cca347ac0651 (patch)
tree5ceb8d0b96b7e94aa8e8416a2f0162d8c15ee38a /package/kernel/linux/modules/netsupport.mk
parent274f04a208bcbb422dc01878d478e16b9422656a (diff)
downloadmaster-187ad058-01afac641e03c5ebb9bde36148d4cca347ac0651.tar.gz
master-187ad058-01afac641e03c5ebb9bde36148d4cca347ac0651.tar.bz2
master-187ad058-01afac641e03c5ebb9bde36148d4cca347ac0651.zip
kernel: remove mp-alg
from upstream commit title: "[IPV4]: The scheduled removal of multipath cached routing support." removed in Kernel 2.6.23 (2007) Reasons: very buggy, no maintainer, no fixes Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45121 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/netsupport.mk')
-rw-r--r--package/kernel/linux/modules/netsupport.mk27
1 files changed, 0 insertions, 27 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 9de1ce2b4f..4ac23c660c 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -843,33 +843,6 @@ endef
$(eval $(call KernelPackage,ax25))
-define KernelPackage/mp-alg
- SUBMENU:=$(NETWORK_SUPPORT_MENU)
- TITLE:=ECMP caching algorithms
- KCONFIG:= \
- CONFIG_IP_ROUTE_MULTIPATH_RR \
- CONFIG_IP_ROUTE_MULTIPATH_RANDOM \
- CONFIG_IP_ROUTE_MULTIPATH_WRANDOM \
- CONFIG_IP_ROUTE_MULTIPATH_DRR
- FILES:= \
- $(LINUX_DIR)/net/ipv4/multipath_rr.ko \
- $(LINUX_DIR)/net/ipv4/multipath_random.ko \
- $(LINUX_DIR)/net/ipv4/multipath_wrandom.ko \
- $(LINUX_DIR)/net/ipv4/multipath_drr.ko
- AUTOLOAD:=$(call AutoLoad,35,multipath_rr multipath_random multipath_wrandom multipath_drr)
-endef
-
-define KernelPackage/mp-alg/description
- Kernel modules that provide several different algorithms for multipath
- route selection from the route cache. The iproute "mpath" argument allows
- specifying which algorithm to use for routes.
- quagga (at least <=0.99.6) requires a multipath patch to support this
- cached mp route feature.
-endef
-
-$(eval $(call KernelPackage,mp-alg))
-
-
define KernelPackage/pktgen
SUBMENU:=$(NETWORK_SUPPORT_MENU)
DEPENDS:=@!TARGET_uml