aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netfilter.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-07-18 11:57:19 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-07-18 11:57:19 +0000
commit7be0ba5341146f05a81cadbc91607053252ca7df (patch)
tree95ee93faf95f567557adf3fdffe755be945ee5de /package/kernel/linux/modules/netfilter.mk
parentdd38ccf62023e76937bc4f6cf7f2e602ea7b0a98 (diff)
downloadmaster-187ad058-7be0ba5341146f05a81cadbc91607053252ca7df.tar.gz
master-187ad058-7be0ba5341146f05a81cadbc91607053252ca7df.tar.bz2
master-187ad058-7be0ba5341146f05a81cadbc91607053252ca7df.zip
linux: add missing dependencies to kmod-ip6tables
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37389 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/netfilter.mk')
-rw-r--r--package/kernel/linux/modules/netfilter.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index 4e4c85f45c..ed02a437f1 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -390,7 +390,7 @@ $(eval $(call KernelPackage,ipt-extra))
define KernelPackage/ip6tables
SUBMENU:=$(NF_MENU)
TITLE:=IPv6 modules
- DEPENDS:=+kmod-ipv6
+ DEPENDS:=+kmod-ipv6 +kmod-ipt-core +kmod-ipt-conntrack
KCONFIG:=$(KCONFIG_IPT_IPV6)
FILES:=$(foreach mod,$(IPT_IPV6-m),$(LINUX_DIR)/net/$(mod).ko)
AUTOLOAD:=$(call AutoLoad,49,$(notdir $(IPT_IPV6-m)))