aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netfilter.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-07-18 15:47:08 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-07-18 15:47:08 +0000
commit20ac95566fe027c065555ed00b7bd7d669cd2069 (patch)
tree6573171d054ba1dd992ba79f873e6eb077b3be55 /package/kernel/linux/modules/netfilter.mk
parent0610b1556dd41a0f91dce4356e8609a29fc7d881 (diff)
downloadmaster-187ad058-20ac95566fe027c065555ed00b7bd7d669cd2069.tar.gz
master-187ad058-20ac95566fe027c065555ed00b7bd7d669cd2069.tar.bz2
master-187ad058-20ac95566fe027c065555ed00b7bd7d669cd2069.zip
linux: add missing netfilter dependencies
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37401 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/netfilter.mk')
-rw-r--r--package/kernel/linux/modules/netfilter.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index ed02a437f1..b8072a79c8 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -295,7 +295,7 @@ $(eval $(call KernelPackage,ipt-led))
define KernelPackage/ipt-tproxy
TITLE:=Transparent proxying support
- DEPENDS+=+IPV6:kmod-ipv6
+ DEPENDS+=+kmod-ipt-conntrack +IPV6:kmod-ipv6 +IPV6:kmod-ip6tables
KCONFIG:= \
CONFIG_NETFILTER_TPROXY \
CONFIG_NETFILTER_XT_MATCH_SOCKET \
@@ -315,6 +315,7 @@ $(eval $(call KernelPackage,ipt-tproxy))
define KernelPackage/ipt-tee
TITLE:=TEE support
+ DEPENDS:=+kmod-ipt-conntrack +IPV6:kmod-ipv6
KCONFIG:= \
CONFIG_NETFILTER_XT_TARGET_TEE
FILES:= \
@@ -406,6 +407,7 @@ ARP_MODULES = arp_tables arpt_mangle arptable_filter
define KernelPackage/arptables
SUBMENU:=$(NF_MENU)
TITLE:=ARP firewalling modules
+ DEPENDS:=+kmod-ipt-core
FILES:=$(LINUX_DIR)/net/ipv4/netfilter/arp*.ko
KCONFIG:=CONFIG_IP_NF_ARPTABLES \
CONFIG_IP_NF_ARPFILTER \
@@ -423,6 +425,7 @@ $(eval $(call KernelPackage,arptables))
define KernelPackage/ebtables
SUBMENU:=$(NF_MENU)
TITLE:=Bridge firewalling modules
+ DEPENDS:=+kmod-ipt-core
FILES:=$(foreach mod,$(EBTABLES-m),$(LINUX_DIR)/net/$(mod).ko)
KCONFIG:=CONFIG_BRIDGE_NETFILTER=y \
$(KCONFIG_EBTABLES)
@@ -562,6 +565,7 @@ $(eval $(call KernelPackage,nf-conntrack-netlink))
define KernelPackage/ipt-hashlimit
SUBMENU:=$(NF_MENU)
TITLE:=Netfilter hashlimit match
+ DEPENDS:=+kmod-ipt-core
KCONFIG:=$(KCONFIG_IPT_HASHLIMIT)
FILES:=$(LINUX_DIR)/net/netfilter/xt_hashlimit.ko
AUTOLOAD:=$(call AutoLoad,50,xt_hashlimit)