aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netfilter.mk
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2015-09-21 21:15:41 +0000
committerSteven Barth <steven@midlink.org>2015-09-21 21:15:41 +0000
commit08248ddf22628b1c626d6bdaf1e60ca2a3e62059 (patch)
treea033e0237c3099e4e8a0170126b7b1c9caff7116 /package/kernel/linux/modules/netfilter.mk
parent68a580202c383afa77ee2a618aba7f7f22a0eeaa (diff)
downloadmaster-187ad058-08248ddf22628b1c626d6bdaf1e60ca2a3e62059.tar.gz
master-187ad058-08248ddf22628b1c626d6bdaf1e60ca2a3e62059.tar.bz2
master-187ad058-08248ddf22628b1c626d6bdaf1e60ca2a3e62059.zip
package: Remove dependencies to kmod-ipv6
Since r46834, IPv6 support is builtin if selected. Therefor, dependencies on kmod-ipv6 can no longer be fulfilled, since it is not a module anymore. Signed-off-by: Arjen de Korte <arjen+openwrt@de-korte.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47022 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/netfilter.mk')
-rw-r--r--package/kernel/linux/modules/netfilter.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index 3a436ac0c5..e21895d417 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -80,7 +80,7 @@ define KernelPackage/nf-conntrack6
SUBMENU:=$(NF_MENU)
TITLE:=Netfilter IPv6 connection tracking
KCONFIG:=$(KCONFIG_NF_CONNTRACK6)
- DEPENDS:=+kmod-ipv6 +kmod-nf-conntrack
+ DEPENDS:=@IPV6 +kmod-nf-conntrack
FILES:=$(foreach mod,$(NF_CONNTRACK6-m),$(LINUX_DIR)/net/$(mod).ko)
AUTOLOAD:=$(call AutoProbe,$(notdir $(NF_CONNTRACK6-m)))
endef
@@ -454,7 +454,7 @@ $(eval $(call KernelPackage,ipt-led))
define KernelPackage/ipt-tproxy
TITLE:=Transparent proxying support
- DEPENDS+=+kmod-ipt-conntrack +IPV6:kmod-ipv6 +IPV6:kmod-ip6tables
+ DEPENDS+=+kmod-ipt-conntrack +IPV6:kmod-ip6tables
KCONFIG:= \
CONFIG_NETFILTER_TPROXY \
CONFIG_NETFILTER_XT_MATCH_SOCKET \
@@ -473,7 +473,7 @@ $(eval $(call KernelPackage,ipt-tproxy))
define KernelPackage/ipt-tee
TITLE:=TEE support
- DEPENDS:=+kmod-ipt-conntrack +IPV6:kmod-ipv6
+ DEPENDS:=+kmod-ipt-conntrack
KCONFIG:= \
CONFIG_NETFILTER_XT_TARGET_TEE
FILES:= \