aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netdevices.mk
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-08-11 20:35:10 +0000
committerLuka Perkov <luka@openwrt.org>2014-08-11 20:35:10 +0000
commit6b2145fca6698555c8f1e5c5373a440f2088e7a3 (patch)
treea64f715cba41287389630147006415e6c2a25bdb /package/kernel/linux/modules/netdevices.mk
parent7d82dc4a822da3d708c566444de19f81c0b0137f (diff)
downloadmaster-187ad058-6b2145fca6698555c8f1e5c5373a440f2088e7a3.tar.gz
master-187ad058-6b2145fca6698555c8f1e5c5373a440f2088e7a3.tar.bz2
master-187ad058-6b2145fca6698555c8f1e5c5373a440f2088e7a3.zip
imx6: kernel: add GW16083 Ethernet Expansion Mezzanine support
The GW16083 Ethernet Expansion Mezzanine adds the following to supported Gateworks baseboards: * 7-port Ethernet Switch * 4x RJ45 ports (ENET1-4) supporing 802.11af/at PoE (with optional PoE module) * 2x RJ45 ports or SFP module (ENET5-6) (auto-selected) This series adds support for a phy driver that adds support for ENET5/ENET6 PHY adding initialization for those PHY's and a polling mechanism that detects SFP insertion and configuration. Signed-off-by: Tim Harvey <tharvey@gateworks.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42147 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/netdevices.mk')
-rw-r--r--package/kernel/linux/modules/netdevices.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index 959e8914a0..8dcdd19119 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -129,6 +129,24 @@ endef
$(eval $(call KernelPackage,et131x))
+define KernelPackage/gw16083
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=Gateworks Ventana Ethernet Expansion Mezzanine driver
+ URL:=http://www.gateworks.com
+ FILES:=$(LINUX_DIR)/drivers/net/phy/gw16083.ko
+ KCONFIG:=CONFIG_GATEWORKS_GW16083
+ DEPENDS:=@TARGET_imx6 @PCI_SUPPORT +kmod-libphy +kmod-igb
+ AUTOLOAD:=$(call AutoLoad,36,gw16083)
+endef
+
+define KernelPackage/gw16083/description
+ This package contains the gw16083 kernel module for supporting the Gateworks
+ Ventana Ethernet Expansion Mezzanine.
+endef
+
+$(eval $(call KernelPackage,gw16083))
+
+
define KernelPackage/swconfig
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=switch configuration API