aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netdevices.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-04-04 06:10:03 +0000
committerJohn Crispin <blogic@openwrt.org>2015-04-04 06:10:03 +0000
commit0d51f91df136edb77a67a99792f06e821e852941 (patch)
tree2f57fc69ec3c6ab4f4f150e6ea4ae9ff9a58b826 /package/kernel/linux/modules/netdevices.mk
parent5951971c18eeb97e1b635d01127632128f6368d5 (diff)
downloadmaster-187ad058-0d51f91df136edb77a67a99792f06e821e852941.tar.gz
master-187ad058-0d51f91df136edb77a67a99792f06e821e852941.tar.bz2
master-187ad058-0d51f91df136edb77a67a99792f06e821e852941.zip
kernel: switch to upstream
This driver is upstream since 2012 (commit: a8e510f682f), so switch to it and remove own sources. Also place it under "Network Devices" menu together with other phy drivers. Signed-off-by: Sergey Ryazanov <ryazanov.s.a@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45269 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/netdevices.mk')
-rw-r--r--package/kernel/linux/modules/netdevices.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index dd8692a8e6..450899878a 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -810,3 +810,20 @@ define KernelPackage/vmxnet3/description
endef
$(eval $(call KernelPackage,vmxnet3))
+
+
+define KernelPackage/spi-ks8995
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=Micrel/Kendin KS8995 Ethernet switch control
+ FILES:=$(LINUX_DIR)/drivers/net/phy/spi_ks8995.ko
+ KCONFIG:=CONFIG_MICREL_KS8995MA \
+ CONFIG_SPI=y \
+ CONFIG_SPI_MASTER=y
+ AUTOLOAD:=$(call AutoLoad,50,spi_ks8995)
+endef
+
+define KernelPackage/spi-ks8995/description
+ Kernel module for Micrel/Kendin KS8995 ethernet switch
+endef
+
+$(eval $(call KernelPackage,spi-ks8995))