aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/lib.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-01-28 12:06:45 +0000
committerJohn Crispin <blogic@openwrt.org>2015-01-28 12:06:45 +0000
commitfa2fd8c699de49c34205b316d7b1590766f6340b (patch)
tree56b09f5348c32b7f2ef15d8b491abbde13f6350a /package/kernel/linux/modules/lib.mk
parent1dfcf9183c7e8dd17beb0c296cebbd4f0bdae633 (diff)
downloadmaster-187ad058-fa2fd8c699de49c34205b316d7b1590766f6340b.tar.gz
master-187ad058-fa2fd8c699de49c34205b316d7b1590766f6340b.tar.bz2
master-187ad058-fa2fd8c699de49c34205b316d7b1590766f6340b.zip
modules: add lz4 compression support
Signed-off-by: Nathan Hintz <nlhintz@hotmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44169 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/lib.mk')
-rw-r--r--package/kernel/linux/modules/lib.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/lib.mk b/package/kernel/linux/modules/lib.mk
index cd919ba62e..f230a99dff 100644
--- a/package/kernel/linux/modules/lib.mk
+++ b/package/kernel/linux/modules/lib.mk
@@ -117,6 +117,26 @@ endef
$(eval $(call KernelPackage,lib-lzo))
+define KernelPackage/lib-lz4
+ SUBMENU:=$(LIB_MENU)
+ DEPENDS:=@!(LINUX_3_3||LINUX_3_8||LINUX_3_10||LINUX_3_13||LINUX_3_14)
+ TITLE:=LZ4 support
+ KCONFIG:= \
+ CONFIG_LZ4_COMPRESS \
+ CONFIG_LZ4_DECOMPRESS
+ FILES:= \
+ $(LINUX_DIR)/lib/lz4/lz4_compress.ko \
+ $(LINUX_DIR)/lib/lz4/lz4_decompress.ko
+ AUTOLOAD:=$(call AutoProbe,lz4_compress lz4_decompress)
+endef
+
+define KernelPackage/lib-lz4/description
+ Kernel module for LZ4 compression/decompression support
+endef
+
+$(eval $(call KernelPackage,lib-lz4))
+
+
define KernelPackage/lib-raid6
SUBMENU:=$(LIB_MENU)
TITLE:=RAID6 algorithm support