aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/lib.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2014-05-02 22:56:33 +0000
committerHauke Mehrtens <hauke@openwrt.org>2014-05-02 22:56:33 +0000
commiteda766a29362f1a93e53eadf37a437d56c71d0b6 (patch)
treecd2a1d1eac1645311c68212b598ca8b555f096fa /package/kernel/linux/modules/lib.mk
parentc5860d782385ce6fcddaf305e6b5916ebdf389fc (diff)
downloadmaster-187ad058-eda766a29362f1a93e53eadf37a437d56c71d0b6.tar.gz
master-187ad058-eda766a29362f1a93e53eadf37a437d56c71d0b6.tar.bz2
master-187ad058-eda766a29362f1a93e53eadf37a437d56c71d0b6.zip
kernel: fix dependency to xor-neon.ko
If this module gets build the xor module depends on it Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40666 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/lib.mk')
-rw-r--r--package/kernel/linux/modules/lib.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/lib.mk b/package/kernel/linux/modules/lib.mk
index af536270f6..cd919ba62e 100644
--- a/package/kernel/linux/modules/lib.mk
+++ b/package/kernel/linux/modules/lib.mk
@@ -138,8 +138,15 @@ define KernelPackage/lib-xor
TITLE:=XOR blocks algorithm support
HIDDEN:=1
KCONFIG:=CONFIG_XOR_BLOCKS
+ifneq ($(wildcard $(LINUX_DIR)/arch/arm/lib/xor-neon.ko),)
+ FILES:= \
+ $(LINUX_DIR)/crypto/xor.ko \
+ $(LINUX_DIR)/arch/arm/lib/xor-neon.ko
+ AUTOLOAD:=$(call AutoProbe,xor-neon xor)
+else
FILES:=$(LINUX_DIR)/crypto/xor.ko
AUTOLOAD:=$(call AutoProbe,xor)
+endif
endef
define KernelPackage/lib-xor/description