aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/input.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-04-02 14:31:02 +0000
committerJohn Crispin <blogic@openwrt.org>2015-04-02 14:31:02 +0000
commitec91d8a6540cbce79ab181bf152e1e392a62ca18 (patch)
treefda0d22a4b562685e0cead30963a903910771eb3 /package/kernel/linux/modules/input.mk
parent151d0e7548b31751ca8c595a4f8f976a579edb0e (diff)
downloadmaster-187ad058-ec91d8a6540cbce79ab181bf152e1e392a62ca18.tar.gz
master-187ad058-ec91d8a6540cbce79ab181bf152e1e392a62ca18.tar.bz2
master-187ad058-ec91d8a6540cbce79ab181bf152e1e392a62ca18.zip
kernel: add uinput module
This module is needed for bluetooth audio playback with pulseaudio 6 and bluez5. a working guide can be found in the wiki: http://wiki.openwrt.org/wiki/bluetooth.audio (additional packages/modifications are required and submitted to github feeds) tested with: Android mobile (Sony Xperia M) as audio source TI omap BeagleBoard as audio sink Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45231 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/input.mk')
-rw-r--r--package/kernel/linux/modules/input.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
index b44136b78c..86ff33cb26 100644
--- a/package/kernel/linux/modules/input.mk
+++ b/package/kernel/linux/modules/input.mk
@@ -205,3 +205,21 @@ define KernelPackage/keyboard-imx/description
endef
$(eval $(call KernelPackage,keyboard-imx))
+
+
+define KernelPackage/input-uinput
+ SUBMENU:=$(INPUT_MODULES_MENU)
+ TITLE:=user input module
+ DEPENDS:=+kmod-input-core
+ KCONFIG:= \
+ CONFIG_INPUT_MISC=y \
+ CONFIG_INPUT_UINPUT
+ FILES:=$(LINUX_DIR)/drivers/input/misc/uinput.ko
+ AUTOLOAD:=$(call AutoProbe,uinput)
+endef
+
+define KernelPackage/input-uinput/description
+ user input modules needed for bluez
+endef
+
+$(eval $(call KernelPackage,input-uinput))