aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/input.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-01-17 07:07:28 +0000
committerJohn Crispin <blogic@openwrt.org>2015-01-17 07:07:28 +0000
commitdb2a099071c00a5188ad417fc38e22c32b3dc52b (patch)
tree78f166e1d5272a675eac062e5f6d1a84a0b7bf81 /package/kernel/linux/modules/input.mk
parent9d149658add276a5dd3e87535a4e05f9d7d70cab (diff)
downloadmaster-187ad058-db2a099071c00a5188ad417fc38e22c32b3dc52b.tar.gz
master-187ad058-db2a099071c00a5188ad417fc38e22c32b3dc52b.tar.bz2
master-187ad058-db2a099071c00a5188ad417fc38e22c32b3dc52b.zip
kernel: add references to openwrt alternative button handling
Add documentation that makes it easier to find the alternative, recommended, and default handling for buttons in OpenWrt. Signed-off-by: Karl Palsson <karlp@tweak.net.au> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43989 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/input.mk')
-rw-r--r--package/kernel/linux/modules/input.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
index 32adc1ecf4..f42cbaec06 100644
--- a/package/kernel/linux/modules/input.mk
+++ b/package/kernel/linux/modules/input.mk
@@ -82,6 +82,9 @@ endef
define KernelPackage/input-gpio-keys/description
This driver implements support for buttons connected
to GPIO pins of various CPUs (and some other chips).
+
+ See also gpio-button-hotplug which is an alternative, lower overhead
+ implementation that generates uevents instead of kernel input events.
endef
$(eval $(call KernelPackage,input-gpio-keys))
@@ -101,6 +104,9 @@ endef
define KernelPackage/input-gpio-keys-polled/description
Kernel module for support polled GPIO keys input device
+
+ See also gpio-button-hotplug which is an alternative, lower overhead
+ implementation that generates uevents instead of kernel input events.
endef
$(eval $(call KernelPackage,input-gpio-keys-polled))