aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/input.mk
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-10-25 10:29:49 +0000
committerLuka Perkov <luka@openwrt.org>2013-10-25 10:29:49 +0000
commitd4b136206219c179981b1dc5508a203c808bd861 (patch)
tree3aefc04c94b134f54a723fea3373ca21a78ae72f /package/kernel/linux/modules/input.mk
parentd2f28c39d8651f715a90d2136e508e3e1f4b2ee5 (diff)
downloadmaster-187ad058-d4b136206219c179981b1dc5508a203c808bd861.tar.gz
master-187ad058-d4b136206219c179981b1dc5508a203c808bd861.tar.bz2
master-187ad058-d4b136206219c179981b1dc5508a203c808bd861.zip
kernel: add keyboard-imx module
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38537 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/input.mk')
-rw-r--r--package/kernel/linux/modules/input.mk20
1 files changed, 19 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
index 421a6b8fca..32adc1ecf4 100644
--- a/package/kernel/linux/modules/input.mk
+++ b/package/kernel/linux/modules/input.mk
@@ -159,7 +159,7 @@ define KernelPackage/input-matrixkmap
KCONFIG:=CONFIG_INPUT_MATRIXKMAP
DEPENDS:=@!LINUX_3_3
FILES:=$(LINUX_DIR)/drivers/input/matrix-keymap.ko
- AUTOLOAD:=$(call AutoLoad,20,matrix-keymap)
+ AUTOLOAD:=$(call AutoProbe,matrix-keymap)
$(call AddDepends/input)
endef
@@ -184,3 +184,21 @@ define KernelPackage/acpi-button/description
endef
$(eval $(call KernelPackage,acpi-button))
+
+
+define KernelPackage/keyboard-imx
+ SUBMENU:=$(INPUT_MODULES_MENU)
+ TITLE:=IMX keypad support
+ DEPENDS:=@(TARGET_mxs||TARGET_imx6) +kmod-input-matrixkmap
+ KCONFIG:= \
+ CONFIG_KEYBOARD_IMX \
+ CONFIG_INPUT_KEYBOARD=y
+ FILES:=$(LINUX_DIR)/drivers/input/keyboard/imx_keypad.ko
+ AUTOLOAD:=$(call AutoProbe,imx_keypad)
+endef
+
+define KernelPackage/keyboard-imx/description
+ Enable support for IMX keypad port.
+endef
+
+$(eval $(call KernelPackage,keyboard-imx))