aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/input.mk
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-07-19 13:20:41 +0000
committerJonas Gorski <jogo@openwrt.org>2013-07-19 13:20:41 +0000
commitb553142b7ee6a1606cec83e5d597563df4061370 (patch)
treefc5ba4c0e9b83b1e315a7d6a90b06e8aaf9faf43 /package/kernel/linux/modules/input.mk
parent2f2a913440e36a5e476a0906ae46a9f05f90013c (diff)
downloadmaster-187ad058-b553142b7ee6a1606cec83e5d597563df4061370.tar.gz
master-187ad058-b553142b7ee6a1606cec83e5d597563df4061370.tar.bz2
master-187ad058-b553142b7ee6a1606cec83e5d597563df4061370.zip
kernel: remove gpio_buttons
It hasn't been buildable for a long time, and there are no users of it anymore left as all of them have been switched to the upstream accepted version. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37436 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/input.mk')
-rw-r--r--package/kernel/linux/modules/input.mk18
1 files changed, 0 insertions, 18 deletions
diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
index 78fa9241cd..f0bc7bd0ad 100644
--- a/package/kernel/linux/modules/input.mk
+++ b/package/kernel/linux/modules/input.mk
@@ -68,24 +68,6 @@ endef
$(eval $(call KernelPackage,input-evdev))
-define KernelPackage/input-gpio-buttons
- SUBMENU:=$(INPUT_MODULES_MENU)
- TITLE:=Polled GPIO buttons input device
- DEPENDS:=@GPIO_SUPPORT +kmod-input-polldev
- KCONFIG:= \
- CONFIG_INPUT_GPIO_BUTTONS \
- CONFIG_INPUT_MISC=y
- FILES:=$(LINUX_DIR)/drivers/input/misc/gpio_buttons.ko
- AUTOLOAD:=$(call AutoLoad,62,gpio_buttons,1)
-endef
-
-define KernelPackage/input-gpio-buttons/description
- Kernel module for support polled GPIO buttons input device
-endef
-
-$(eval $(call KernelPackage,input-gpio-buttons))
-
-
define KernelPackage/input-gpio-keys
SUBMENU:=$(INPUT_MODULES_MENU)
TITLE:=GPIO key support