aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/input.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-07-14 17:23:56 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-07-14 17:23:56 +0000
commitb4018fe87961a792aa0f953f53d8561c69fa33c6 (patch)
tree472a86315626bf81d938a24a6cfa1680857c72bc /package/kernel/linux/modules/input.mk
parentab8177c34df6ee4e2991f62be58e10a31defcd98 (diff)
downloadmaster-187ad058-b4018fe87961a792aa0f953f53d8561c69fa33c6.tar.gz
master-187ad058-b4018fe87961a792aa0f953f53d8561c69fa33c6.tar.bz2
master-187ad058-b4018fe87961a792aa0f953f53d8561c69fa33c6.zip
linux: enable kmod-acpi-button for x86_64 (#20080)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46368 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/input.mk')
-rw-r--r--package/kernel/linux/modules/input.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
index 86ff33cb26..0539493cbd 100644
--- a/package/kernel/linux/modules/input.mk
+++ b/package/kernel/linux/modules/input.mk
@@ -176,7 +176,7 @@ $(eval $(call KernelPackage,input-matrixkmap))
define KernelPackage/acpi-button
SUBMENU:=$(INPUT_MODULES_MENU)
TITLE:=ACPI Button Support
- DEPENDS:=@(TARGET_x86_generic||TARGET_x86_kvm_guest||TARGET_x86_xen_domu) +kmod-input-evdev
+ DEPENDS:=@(TARGET_x86_generic||TARGET_x86_kvm_guest||TARGET_x86_xen_domu||TARGET_x86_64) +kmod-input-evdev
KCONFIG:=CONFIG_ACPI_BUTTON
FILES:=$(LINUX_DIR)/drivers/acpi/button.ko
AUTOLOAD:=$(call AutoLoad,06,button)