aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/input.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-09-17 21:45:17 +0000
committerJohn Crispin <blogic@openwrt.org>2013-09-17 21:45:17 +0000
commit751f92881546b07452e922ad15be9d446f23f592 (patch)
tree2659076169733540dabefd531b086be6ce69f345 /package/kernel/linux/modules/input.mk
parenta1d883cc85daebe3acdcbb5e61183db57040d02a (diff)
downloadmaster-187ad058-751f92881546b07452e922ad15be9d446f23f592.tar.gz
master-187ad058-751f92881546b07452e922ad15be9d446f23f592.tar.bz2
master-187ad058-751f92881546b07452e922ad15be9d446f23f592.zip
kernel: make most modules use AutoProbe
now that we have modprobe we can set more than half of the modules to AutoProbe Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38021 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/input.mk')
-rw-r--r--package/kernel/linux/modules/input.mk12
1 files changed, 5 insertions, 7 deletions
diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
index 1daaad3471..421a6b8fca 100644
--- a/package/kernel/linux/modules/input.mk
+++ b/package/kernel/linux/modules/input.mk
@@ -27,7 +27,7 @@ define KernelPackage/hid-generic
TITLE:=Generic HID device support
KCONFIG:=CONFIG_HID_GENERIC
FILES:=$(LINUX_DIR)/drivers/hid/hid-generic.ko
- AUTOLOAD:=$(call AutoLoad,62,hid-generic)
+ AUTOLOAD:=$(call AutoProbe,hid-generic)
$(call AddDepends/hid)
endef
@@ -42,7 +42,6 @@ define KernelPackage/input-core
TITLE:=Input device core
KCONFIG:=CONFIG_INPUT
FILES:=$(LINUX_DIR)/drivers/input/input-core.ko
- AUTOLOAD:=$(call AutoLoad,19,input-core,1)
endef
define KernelPackage/input-core/description
@@ -76,7 +75,7 @@ define KernelPackage/input-gpio-keys
CONFIG_KEYBOARD_GPIO \
CONFIG_INPUT_KEYBOARD=y
FILES:=$(LINUX_DIR)/drivers/input/keyboard/gpio_keys.ko
- AUTOLOAD:=$(call AutoLoad,60,gpio_keys)
+ AUTOLOAD:=$(call AutoProbe,gpio_keys)
$(call AddDepends/input)
endef
@@ -96,7 +95,7 @@ define KernelPackage/input-gpio-keys-polled
CONFIG_KEYBOARD_GPIO_POLLED \
CONFIG_INPUT_KEYBOARD=y
FILES:=$(LINUX_DIR)/drivers/input/keyboard/gpio_keys_polled.ko
- AUTOLOAD:=$(call AutoLoad,62,gpio_keys_polled,1)
+ AUTOLOAD:=$(call AutoProbe,gpio_keys_polled,1)
$(call AddDepends/input)
endef
@@ -112,7 +111,7 @@ define KernelPackage/input-gpio-encoder
TITLE:=GPIO rotay encoder
KCONFIG:=CONFIG_INPUT_GPIO_ROTARY_ENCODER
FILES:=$(LINUX_DIR)/drivers/input/misc/rotary_encoder.ko
- AUTOLOAD:=$(call AutoLoad,62,rotary_encoder)
+ AUTOLOAD:=$(call AutoProbe,rotary_encoder)
$(call AddDepends/input,@GPIO_SUPPORT)
endef
@@ -128,7 +127,7 @@ define KernelPackage/input-joydev
TITLE:=Joystick device support
KCONFIG:=CONFIG_INPUT_JOYDEV
FILES:=$(LINUX_DIR)/drivers/input/joydev.ko
- AUTOLOAD:=$(call AutoLoad,62,joydev)
+ AUTOLOAD:=$(call AutoProbe,joydev)
$(call AddDepends/input)
endef
@@ -144,7 +143,6 @@ define KernelPackage/input-polldev
TITLE:=Polled Input device support
KCONFIG:=CONFIG_INPUT_POLLDEV
FILES:=$(LINUX_DIR)/drivers/input/input-polldev.ko
- AUTOLOAD:=$(call AutoLoad,20,input-polldev,1)
$(call AddDepends/input)
endef