aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/i2c.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-25 18:00:33 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-25 18:00:33 +0000
commitdc45d360daca6e61c614d6818a337bcd194c33d4 (patch)
tree2d35a65b93b8c25e69f1c18b55de668f3e905d0f /package/kernel/linux/modules/i2c.mk
parent043888a5f3a9d3ebd4ca5a2ae9e086ff7a0faebc (diff)
downloadmaster-187ad058-dc45d360daca6e61c614d6818a337bcd194c33d4.tar.gz
master-187ad058-dc45d360daca6e61c614d6818a337bcd194c33d4.tar.bz2
master-187ad058-dc45d360daca6e61c614d6818a337bcd194c33d4.zip
package/kernel: move I2C-GPIO drivers from i2c.mk to other.mk
Move pca953x support from i2c.mk to other.mk, where other GPIO drivers are located. Remove duplicate pcf857x support from i2c.mk. Signed-off-by: Hartmut Knaack <knaack.h@gmx.de> [juhosg: update subject, and reformat commit message] Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38185 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/i2c.mk')
-rw-r--r--package/kernel/linux/modules/i2c.mk31
1 files changed, 0 insertions, 31 deletions
diff --git a/package/kernel/linux/modules/i2c.mk b/package/kernel/linux/modules/i2c.mk
index f1eea31807..8a26f42e75 100644
--- a/package/kernel/linux/modules/i2c.mk
+++ b/package/kernel/linux/modules/i2c.mk
@@ -237,34 +237,3 @@ define KernelPackage/i2c-mux-pca9541/description
endef
$(eval $(call KernelPackage,i2c-mux-pca9541))
-
-GPIO_PCA953X_MODULES:= \
- CONFIG_GPIO_PCA953X:drivers/gpio/gpio-pca953x
-
-define KernelPackage/pca953x
- $(call i2c_defaults,$(GPIO_PCA953X_MODULES),51)
- TITLE:=Philips PCA953x I2C GPIO extenders
- DEPENDS:=kmod-i2c-core
-endef
-
-define KernelPackage/pca953x/description
- Kernel modules for PCA953x I2C GPIO extenders
-endef
-
-$(eval $(call KernelPackage,pca953x))
-
-
-GPIO_PCF857X_MODULES:= \
- CONFIG_GPIO_PCF857X:drivers/gpio/gpio-pcf857x
-
-define KernelPackage/pcf857x
- $(call i2c_defaults,$(GPIO_PCF857X_MODULES),51)
- TITLE:=Philips PCF857x I2C GPIO extenders
- DEPENDS:=kmod-i2c-core
-endef
-
-define KernelPackage/pcf857x/description
- Kernel modules for PCF857x I2C GPIO extenders
-endef
-
-$(eval $(call KernelPackage,pcf857x))