aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/i2c.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-10-24 09:24:45 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-10-24 09:24:45 +0000
commit16f737c9002534673891299318b2d805c0d71dc7 (patch)
treedfcd82eaf8c1489cfaf838b7640c01180dcf3bc4 /package/kernel/linux/modules/i2c.mk
parent765e350fdc442ecbeb96ff005b79689939643f4a (diff)
downloadmaster-187ad058-16f737c9002534673891299318b2d805c0d71dc7.tar.gz
master-187ad058-16f737c9002534673891299318b2d805c0d71dc7.tar.bz2
master-187ad058-16f737c9002534673891299318b2d805c0d71dc7.zip
linux: add kmod-i2c-piix4
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43040 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/i2c.mk')
-rw-r--r--package/kernel/linux/modules/i2c.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/i2c.mk b/package/kernel/linux/modules/i2c.mk
index c0f9f813ec..51c6f59753 100644
--- a/package/kernel/linux/modules/i2c.mk
+++ b/package/kernel/linux/modules/i2c.mk
@@ -170,6 +170,28 @@ endef
$(eval $(call KernelPackage,i2c-tiny-usb))
+
+I2C_PIIX4_MODULES:= \
+ CONFIG_I2C_PIIX4:drivers/i2c/busses/i2c-piix4
+
+define KernelPackage/i2c-piix4
+ $(call i2c_defaults,$(I2C_PIIX4_MODULES),59)
+ TITLE:=Intel PIIX4 and compatible I2C interfaces
+ DEPENDS:=@PCI_SUPPORT @(x86||x86_64) kmod-i2c-core
+endef
+
+define KernelPackage/i2c-piix4/description
+ Support for the Intel PIIX4 family of mainboard I2C interfaces,
+ specifically Intel PIIX4, Intel 440MX, ATI IXP200, ATI IXP300,
+ ATI IXP400, ATI SB600, ATI SB700/SP5100, ATI SB800, AMD Hudson-2,
+ AMD ML, AMD CZ, Serverworks OSB4, Serverworks CSB5,
+ Serverworks CSB6, Serverworks HT-1000, Serverworks HT-1100 and
+ SMSC Victory66.
+endef
+
+$(eval $(call KernelPackage,i2c-piix4))
+
+
I2C_MUX_MODULES:= \
CONFIG_I2C_MUX:drivers/i2c/i2c-mux