aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/hwmon.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-12-22 19:05:35 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-12-22 19:05:35 +0000
commitfe0d191dc1a047449b1232ec170b0e0472c9d248 (patch)
tree7f01451a12f05874f18495ce047668f1a97c8f89 /package/kernel/linux/modules/hwmon.mk
parente63b0a78e9da52deab44a101289b8746fa7882a0 (diff)
downloadmaster-187ad058-fe0d191dc1a047449b1232ec170b0e0472c9d248.tar.gz
master-187ad058-fe0d191dc1a047449b1232ec170b0e0472c9d248.tar.bz2
master-187ad058-fe0d191dc1a047449b1232ec170b0e0472c9d248.zip
kernel: make kmod-thermal dependency conditional to match upstream kernel module configuration dependency
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47961 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/hwmon.mk')
-rw-r--r--package/kernel/linux/modules/hwmon.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index ad1c7bf91d..e09efa17c0 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -274,7 +274,7 @@ define KernelPackage/hwmon-gpiofan
KCONFIG:=CONFIG_SENSORS_GPIO_FAN
FILES:=$(LINUX_DIR)/drivers/hwmon/gpio-fan.ko
AUTOLOAD:=$(call AutoLoad,60,gpio-fan)
- $(call AddDepends/hwmon,+kmod-i2c-core +kmod-thermal)
+ $(call AddDepends/hwmon,+kmod-i2c-core +PACKAGE_kmod-thermal:kmod-thermal)
endef
define KernelPackage/hwmon-gpiofan/description