aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/hwmon.mk
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-09-10 22:26:30 +0000
committerLuka Perkov <luka@openwrt.org>2013-09-10 22:26:30 +0000
commitecd7cc93fa915a49d3187c028ce0e3b36be5ac13 (patch)
treec422e7056ad7b39e5e818b9a41fa5359a352ebfa /package/kernel/linux/modules/hwmon.mk
parent7801793fac376991f74d798323d1db77c133905d (diff)
downloadmaster-187ad058-ecd7cc93fa915a49d3187c028ce0e3b36be5ac13.tar.gz
master-187ad058-ecd7cc93fa915a49d3187c028ce0e3b36be5ac13.tar.bz2
master-187ad058-ecd7cc93fa915a49d3187c028ce0e3b36be5ac13.zip
kernel: allow hwmon GSC driver for all targets
- enable using hwmon GSC driver on all targets - add a kmod package for it Signed-off-by: Tim Harvey <tharvey@gateworks.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37933 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/hwmon.mk')
-rw-r--r--package/kernel/linux/modules/hwmon.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 5af311df66..b1f4744330 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -219,3 +219,18 @@ define KernelPacakge/hwmon-w83627hf/description
endef
$(eval $(call KernelPackage,hwmon-w83627hf))
+
+
+define KernelPackage/hwmon-gsc
+ TITLE:=Gateworks GSC monitoring support
+ KCONFIG:=CONFIG_SENSORS_GSC
+ FILES:=$(LINUX_DIR)/drivers/hwmon/gsc.ko
+ AUTOLOAD:=$(call AutoLoad,50,gsc)
+$(call AddDepends/hwmon)
+endef
+
+define KernelPacakge/hwmon-gsc/description
+ Kernel module for the Gateworks System Controller chips.
+endef
+
+$(eval $(call KernelPackage,hwmon-gsc))