aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/hwmon.mk
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-06-20 20:42:47 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-06-20 20:42:47 +0000
commit10c5dff2322884a13292cdc8ce8d6fbd6103b2d9 (patch)
tree5f7302d3e24e8ab7e798d70842226f564f78defa /package/kernel/linux/modules/hwmon.mk
parent2c20232384a3b2052450fa5e173d3f037721b680 (diff)
downloadmaster-187ad058-10c5dff2322884a13292cdc8ce8d6fbd6103b2d9.tar.gz
master-187ad058-10c5dff2322884a13292cdc8ce8d6fbd6103b2d9.tar.bz2
master-187ad058-10c5dff2322884a13292cdc8ce8d6fbd6103b2d9.zip
[kernel]: package the gpio-fan module
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41289 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/hwmon.mk')
-rw-r--r--package/kernel/linux/modules/hwmon.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 7831f701a2..459e5205ae 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -259,6 +259,7 @@ endef
$(eval $(call KernelPackage,hwmon-gsc))
+
define KernelPackage/hwmon-tmp421
TITLE:=TI TMP421 and compatible monitoring support
KCONFIG:=CONFIG_SENSORS_TMP421
@@ -272,3 +273,18 @@ define KernelPacakge/hwmon-tmp421/description
endef
$(eval $(call KernelPackage,hwmon-tmp421))
+
+
+define KernelPackage/hwmon-gpiofan
+ TITLE:=Generic GPIO FAN support
+ KCONFIG:=CONFIG_SENSORS_GPIO_FAN
+ FILES:=$(LINUX_DIR)/drivers/hwmon/gpio-fan.ko
+ AUTOLOAD:=$(call AutoLoad,60,gpio-fan)
+ $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPacakge/hwmon-gpiofan/description
+ Kernel module for GPIO controlled FANs
+endef
+
+$(eval $(call KernelPackage,hwmon-gpiofan))