aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/fs.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-01-24 20:02:09 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-01-24 20:02:09 +0000
commitae62798e994a3565b8a1f9e98b40bf33123813fc (patch)
tree86c0693badcb7555cddeb4efc4c5d2ecafe331a8 /package/kernel/linux/modules/fs.mk
parentcac0cf6daa5df1faed5bc0f7fc764506e93bace0 (diff)
downloadmaster-187ad058-ae62798e994a3565b8a1f9e98b40bf33123813fc.tar.gz
master-187ad058-ae62798e994a3565b8a1f9e98b40bf33123813fc.tar.bz2
master-187ad058-ae62798e994a3565b8a1f9e98b40bf33123813fc.zip
build: drop obsolete kernel version dependencies
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44110 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/fs.mk')
-rw-r--r--package/kernel/linux/modules/fs.mk7
1 files changed, 3 insertions, 4 deletions
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index 3ae3c2d9b9..8d2731d199 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -62,7 +62,7 @@ $(eval $(call KernelPackage,fs-autofs4))
define KernelPackage/fs-btrfs
SUBMENU:=$(FS_MENU)
TITLE:=BTRFS filesystem support
- DEPENDS:=+kmod-lib-crc32c +kmod-lib-lzo +kmod-lib-zlib +(!LINUX_3_3&&!LINUX_3_6&&!LINUX_3_8):kmod-lib-raid6 +(!LINUX_3_3&&!LINUX_3_6&&!LINUX_3_8):kmod-lib-xor
+ DEPENDS:=+kmod-lib-crc32c +kmod-lib-lzo +kmod-lib-zlib +!LINUX_3_8:kmod-lib-raid6 +!LINUX_3_8:kmod-lib-xor
KCONFIG:=\
CONFIG_BTRFS_FS \
CONFIG_BTRFS_FS_POSIX_ACL=n \
@@ -96,7 +96,7 @@ define KernelPackage/fs-cifs
+kmod-crypto-md4 \
+kmod-crypto-des \
+kmod-crypto-ecb \
- +!LINUX_3_3&&!LINUX_3_6:kmod-crypto-sha256
+ +kmod-crypto-sha256
endef
define KernelPackage/fs-cifs/description
@@ -163,7 +163,7 @@ define KernelPackage/fs-ext4
$(LINUX_DIR)/fs/jbd2/jbd2.ko \
$(LINUX_DIR)/fs/mbcache.ko
AUTOLOAD:=$(call AutoLoad,30,mbcache jbd2 ext4,1)
- $(call AddDepends/crc16, +!LINUX_3_3:kmod-crypto-hash)
+ $(call AddDepends/crc16, +kmod-crypto-hash)
endef
define KernelPackage/fs-ext4/description
@@ -176,7 +176,6 @@ $(eval $(call KernelPackage,fs-ext4))
define KernelPackage/fs-f2fs
SUBMENU:=$(FS_MENU)
TITLE:=F2FS filesystem support
- DEPENDS:=@!LINUX_3_3
KCONFIG:= \
CONFIG_F2FS_FS \
CONFIG_F2FS_STAT_FS=y \