aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/dsa.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-02-15 18:45:34 +0000
committerJohn Crispin <blogic@openwrt.org>2016-02-15 18:45:34 +0000
commit2f2505d5ad933ce6ad408d0c95f1408d45d60511 (patch)
tree2d922fc7d0ed7d7b38e3d1db1b2306445152b6b2 /package/kernel/linux/modules/dsa.mk
parent039db20e04c22af13fe389342f81026476883a15 (diff)
downloadmaster-187ad058-2f2505d5ad933ce6ad408d0c95f1408d45d60511.tar.gz
master-187ad058-2f2505d5ad933ce6ad408d0c95f1408d45d60511.tar.bz2
master-187ad058-2f2505d5ad933ce6ad408d0c95f1408d45d60511.zip
kernel: add missing libphy dep to DSA
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48723 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/dsa.mk')
-rw-r--r--package/kernel/linux/modules/dsa.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/dsa.mk b/package/kernel/linux/modules/dsa.mk
index 0696d754d5..5f19a3f7b4 100644
--- a/package/kernel/linux/modules/dsa.mk
+++ b/package/kernel/linux/modules/dsa.mk
@@ -18,6 +18,7 @@ define KernelPackage/dsa
CONFIG_NET_DSA \
CONFIG_NET_SWITCHDEV=y \
CONFIG_NET_DSA_HWMON=n
+ DEPENDS:=+kmod-libphy
FILES:=$(LINUX_DIR)/net/dsa/dsa_core.ko
AUTOLOAD:=$(call AutoLoad,34,dsa_core)
endef