aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-18 23:35:12 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-18 23:35:12 +0000
commite49407e54cfc5ef73c6340a898a399b6a4919166 (patch)
tree79ffebdf823311e3fa18c6300324495905c37f05 /package/kernel/linux/modules/crypto.mk
parent1f79d0302dee1cd03e2578ae509383942210affb (diff)
downloadmaster-187ad058-e49407e54cfc5ef73c6340a898a399b6a4919166.tar.gz
master-187ad058-e49407e54cfc5ef73c6340a898a399b6a4919166.tar.bz2
master-187ad058-e49407e54cfc5ef73c6340a898a399b6a4919166.zip
kernel/modules: add missing symbol for crypto-rng
Since CRYPTO_DRBG_MENU was added in r48277, CRYPTO_DRBG_HMAC is missing. It does not appear in kernel_menuconfig and defaults to yes, so enable it in crypto-rng as well and add dependencies to HMAC and SHA256. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48341 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index d84c802f91..7c710531cc 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -100,10 +100,11 @@ $(eval $(call KernelPackage,crypto-wq))
define KernelPackage/crypto-rng
TITLE:=CryptoAPI random number generation
- DEPENDS:=+kmod-crypto-hash
+ DEPENDS:=+kmod-crypto-hash +kmod-crypto-hmac +kmod-crypto-sha256
KCONFIG:= \
- CONFIG_CRYPTO_DRBG_MENU \
CONFIG_CRYPTO_DRBG \
+ CONFIG_CRYPTO_DRBG_HMAC=y \
+ CONFIG_CRYPTO_DRBG_MENU \
CONFIG_CRYPTO_JITTERENTROPY \
CONFIG_CRYPTO_RNG2
FILES:= \