aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-29 05:20:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-29 05:20:50 +0000
commitd8f55b0ab66fa7dac10b85011435598624cad801 (patch)
treef005b6cda8c79d9e599dedeed494c6fe970619c7 /package/kernel/linux/modules/crypto.mk
parent136d504c343f75c4e749f2b63c00a9f2d328aeb8 (diff)
downloadmaster-187ad058-d8f55b0ab66fa7dac10b85011435598624cad801.tar.gz
master-187ad058-d8f55b0ab66fa7dac10b85011435598624cad801.tar.bz2
master-187ad058-d8f55b0ab66fa7dac10b85011435598624cad801.zip
linux: modules: crypto: adds ccm package
This patch adds support crypto-ccm modules support. Signed-off-by: Varka Bhadram <varkab@cdac.in> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45123 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index d1ae061460..7d47aed9ca 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -316,6 +316,17 @@ endef
$(eval $(call KernelPackage,crypto-ctr))
+define KernelPackage/crypto-ccm
+ TITLE:=Support for Counter with CBC MAC (CCM)
+ DEPENDS:=+kmod-crypto-ctr +kmod-crypto-aead
+ KCONFIG:=CONFIG_CRYPTO_CCM
+ FILES:=$(LINUX_DIR)/crypto/ccm.ko
+ AUTOLOAD:=$(call AutoLoad,09,ccm)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-ccm))
+
define KernelPackage/crypto-pcbc
TITLE:=Propagating Cipher Block Chaining CryptoAPI module
DEPENDS:=+kmod-crypto-manager