aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-11-08 12:44:38 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-11-08 12:44:38 +0000
commitc7080dcbb1aa3e7c5f721e21a38b05060de0f955 (patch)
treec29f003e41b07596aa0b0dff976c1dd1def8e893 /package/kernel/linux/modules/crypto.mk
parentd07f0dcda12a06a8c40606610ff606fab54bd123 (diff)
downloadmaster-187ad058-c7080dcbb1aa3e7c5f721e21a38b05060de0f955.tar.gz
master-187ad058-c7080dcbb1aa3e7c5f721e21a38b05060de0f955.tar.bz2
master-187ad058-c7080dcbb1aa3e7c5f721e21a38b05060de0f955.zip
[omap]: switch to 3.12, enable support for AM33xx/OMAP3
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38692 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index bb5bb2854b..7996d03fd3 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -205,6 +205,28 @@ endef
$(eval $(call KernelPackage,crypto-hw-ppc4xx))
+define KernelPackage/crypto-hw-omap
+ TITLE:=TI OMAP hardware crypto modules
+ DEPENDS:=@TARGET_omap4
+ KCONFIG:= \
+ CONFIG_CRYPTO_DEV_OMAP_AES \
+ CONFIG_CRYPTO_DEV_OMAP_DES \
+ CONFIG_CRYPTO_DEV_OMAP_SHAM
+ FILES:= \
+ $(LINUX_DIR)/drivers/crypto/omap-aes.ko \
+ $(LINUX_DIR)/drivers/crypto/omap-des.ko \
+ $(LINUX_DIR)/drivers/crypto/omap-sham.ko
+ AUTOLOAD:=$(call AutoLoad,90,omap-aes omap-des omap-sham)
+ $(call AddDepends/crypto,+kmod-crypto-manager +kmod-crypto-hash)
+endef
+
+define KernelPackage/crypto-hw-omap/description
+ Kernel support for the TI OMAP HW crypto engine.
+endef
+
+$(eval $(call KernelPackage,crypto-hw-omap))
+
+
define KernelPackage/crypto-aes
TITLE:=AES cipher CryptoAPI module
KCONFIG:=CONFIG_CRYPTO_AES CONFIG_CRYPTO_AES_586