aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-12-11 19:21:49 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-12-11 19:21:49 +0000
commitc2beb5f892af9889d39f0f26cdcc8e1563264b44 (patch)
tree92ac38c5f560eabbcfa4c585895c42455dd2f7c9 /package/kernel/linux/modules/crypto.mk
parent7bc1a76b12b5be399cb96b05b664840d2996c82a (diff)
downloadmaster-187ad058-c2beb5f892af9889d39f0f26cdcc8e1563264b44.tar.gz
master-187ad058-c2beb5f892af9889d39f0f26cdcc8e1563264b44.tar.bz2
master-187ad058-c2beb5f892af9889d39f0f26cdcc8e1563264b44.zip
kernel: crypto-aead depends on crypto-null in 4.3 as well
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47870 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index fe64db46f7..dc817eed5f 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -27,7 +27,7 @@ define KernelPackage/crypto-aead
CONFIG_CRYPTO_AEAD2
FILES:=$(LINUX_DIR)/crypto/aead.ko
AUTOLOAD:=$(call AutoLoad,09,aead,1)
- $(call AddDepends/crypto, +LINUX_4_4:kmod-crypto-null)
+ $(call AddDepends/crypto, +LINUX_4_3:kmod-crypto-null +LINUX_4_4:kmod-crypto-null)
endef
$(eval $(call KernelPackage,crypto-aead))