aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-11-17 14:30:42 +0000
committerJohn Crispin <blogic@openwrt.org>2014-11-17 14:30:42 +0000
commita1e3550b3736a762ced948355f03d9088a693bc1 (patch)
treefef15cd7ee1f9373be9462c5befa031f8ce9f8f0 /package/kernel/linux/modules/crypto.mk
parent822237afe464007260f561d3ca0c589fd29b9724 (diff)
downloadmaster-187ad058-a1e3550b3736a762ced948355f03d9088a693bc1.tar.gz
master-187ad058-a1e3550b3736a762ced948355f03d9088a693bc1.tar.bz2
master-187ad058-a1e3550b3736a762ced948355f03d9088a693bc1.zip
kernel/modules: use crc32c_generic.ko instead of crc32c.ko
Starting from kernel version 3.15, the crc32c module was renamed to crc32c_generic. Signed-off-by: Daniel Golle <daniel@makrotopia.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43291 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index efa69b7590..e0a2e27256 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -299,8 +299,13 @@ define KernelPackage/crypto-crc32c
TITLE:=CRC32c CRC module
DEPENDS:=+kmod-crypto-hash
KCONFIG:=CONFIG_CRYPTO_CRC32C
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.15.0)),1)
+ FILES:=$(LINUX_DIR)/crypto/crc32c_generic.ko
+ AUTOLOAD:=$(call AutoLoad,04,crc32c_generic,1)
+else
FILES:=$(LINUX_DIR)/crypto/crc32c.ko
AUTOLOAD:=$(call AutoLoad,04,crc32c,1)
+endif
$(call AddDepends/crypto)
endef