aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-17 11:17:06 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-17 11:17:06 +0000
commita0cfc05f8ff7c88ed592c4f8960fe1136bb9fbce (patch)
tree8d080ff59b8673378eb45d5c1c37d21316ebc55a /package/kernel/linux/modules/crypto.mk
parent8cf7f1685def57cd5677de8b3cf965042f7ef6a5 (diff)
downloadmaster-187ad058-a0cfc05f8ff7c88ed592c4f8960fe1136bb9fbce.tar.gz
master-187ad058-a0cfc05f8ff7c88ed592c4f8960fe1136bb9fbce.tar.bz2
master-187ad058-a0cfc05f8ff7c88ed592c4f8960fe1136bb9fbce.zip
kernel: add missing kernel config symbol for crypto-rng (fixes #21596)
Signed-off-by: Lucian Cristian <luci@createc.ro> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48277 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 604be9fce9..d84c802f91 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -102,6 +102,7 @@ define KernelPackage/crypto-rng
TITLE:=CryptoAPI random number generation
DEPENDS:=+kmod-crypto-hash
KCONFIG:= \
+ CONFIG_CRYPTO_DRBG_MENU \
CONFIG_CRYPTO_DRBG \
CONFIG_CRYPTO_JITTERENTROPY \
CONFIG_CRYPTO_RNG2