aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-29 04:32:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-29 04:32:01 +0000
commit795063e4bd943a6f8b10d4ed11ddce8aad604771 (patch)
treebd27c2604891a5f0871e47c5a5027278ce4b9029 /package/kernel/linux/modules/crypto.mk
parenta12f75fc15f858afc69fcf64d8bc8fc526bc7fdc (diff)
downloadmaster-187ad058-795063e4bd943a6f8b10d4ed11ddce8aad604771.tar.gz
master-187ad058-795063e4bd943a6f8b10d4ed11ddce8aad604771.tar.bz2
master-187ad058-795063e4bd943a6f8b10d4ed11ddce8aad604771.zip
x86: make x86_64 a subtarget instead of a standalone target
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45115 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk18
1 files changed, 11 insertions, 7 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 4df2d7393a..d1ae061460 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -262,10 +262,12 @@ define KernelPackage/crypto-aes
$(call AddDepends/crypto)
endef
-define KernelPackage/crypto-aes/x86
- FILES+=$(LINUX_DIR)/arch/x86/crypto/aes-i586.ko
- AUTOLOAD:=$(call AutoLoad,09,aes-i586)
-endef
+ifndef CONFIG_TARGET_x86_64
+ define KernelPackage/crypto-aes/x86
+ FILES+=$(LINUX_DIR)/arch/x86/crypto/aes-i586.ko
+ AUTOLOAD:=$(call AutoLoad,09,aes-i586)
+ endef
+endif
$(eval $(call KernelPackage,crypto-aes))
@@ -530,9 +532,11 @@ define KernelPackage/crypto-misc
$(call AddDepends/crypto)
endef
-define KernelPackage/crypto-misc/x86
- FILES+=$(LINUX_DIR)/arch/x86/crypto/twofish-i586.ko
-endef
+ifndef CONFIG_TARGET_x86_64
+ define KernelPackage/crypto-misc/x86
+ FILES+=$(LINUX_DIR)/arch/x86/crypto/twofish-i586.ko
+ endef
+endif
$(eval $(call KernelPackage,crypto-misc))