aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-15 21:33:39 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-15 21:33:39 +0000
commit700aefac6c0c84759cbec6f594db1a4657a8ebfb (patch)
treece4a7dec146d8bb9984fd73c5239b553a35925c0 /package/kernel/linux/modules/crypto.mk
parent0a45b75790192fbd0d1a765e9446ae6ce9b9d775 (diff)
downloadmaster-187ad058-700aefac6c0c84759cbec6f594db1a4657a8ebfb.tar.gz
master-187ad058-700aefac6c0c84759cbec6f594db1a4657a8ebfb.tar.bz2
master-187ad058-700aefac6c0c84759cbec6f594db1a4657a8ebfb.zip
kernel/modules: add OCTEON MD5 module
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47475 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk9
1 files changed, 8 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 20fc858943..0981102b8f 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -442,12 +442,19 @@ $(eval $(call KernelPackage,crypto-md4))
define KernelPackage/crypto-md5
TITLE:=MD5 digest CryptoAPI module
DEPENDS:=+kmod-crypto-hash
- KCONFIG:=CONFIG_CRYPTO_MD5
+ KCONFIG:= \
+ CONFIG_CRYPTO_MD5 \
+ CONFIG_CRYPTO_MD5_OCTEON
FILES:=$(LINUX_DIR)/crypto/md5.ko
AUTOLOAD:=$(call AutoLoad,09,md5)
$(call AddDepends/crypto)
endef
+define KernelPackage/crypto-md5/octeon
+ FILES+=$(LINUX_DIR)/arch/mips/cavium-octeon/crypto/octeon-md5.ko
+ AUTOLOAD:=$(call AutoLoad,09,octeon-md5)
+endef
+
$(eval $(call KernelPackage,crypto-md5))