aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/block.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-04 20:25:13 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-07-04 20:25:13 +0200
commitd818da7f77c8cd7fe8e66fb2e2ecd0590b1e9e8e (patch)
tree7d0b6d34fb4414684d233b8ee9f10c5ea7925a2b /package/kernel/linux/modules/block.mk
parenta1f8d578031ef765d873fde6f6722fc506176eb5 (diff)
downloadmaster-187ad058-d818da7f77c8cd7fe8e66fb2e2ecd0590b1e9e8e.tar.gz
master-187ad058-d818da7f77c8cd7fe8e66fb2e2ecd0590b1e9e8e.tar.bz2
master-187ad058-d818da7f77c8cd7fe8e66fb2e2ecd0590b1e9e8e.zip
mvebu: enable core drivers in the kernel config instead of packaging them
Simplify profile package selection Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/linux/modules/block.mk')
-rw-r--r--package/kernel/linux/modules/block.mk18
1 files changed, 1 insertions, 17 deletions
diff --git a/package/kernel/linux/modules/block.mk b/package/kernel/linux/modules/block.mk
index 0c8d9b1fe9..d7f5ca4762 100644
--- a/package/kernel/linux/modules/block.mk
+++ b/package/kernel/linux/modules/block.mk
@@ -65,7 +65,7 @@ define KernelPackage/ata-ahci-platform
$(LINUX_DIR)/drivers/ata/ahci_platform.ko \
$(LINUX_DIR)/drivers/ata/libahci_platform.ko
AUTOLOAD:=$(call AutoLoad,40,libahci libahci_platform ahci_platform,1)
- $(call AddDepends/ata,@TARGET_ipq806x||TARGET_mvebu||TARGET_sunxi)
+ $(call AddDepends/ata,@TARGET_ipq806x||TARGET_sunxi)
endef
define KernelPackage/ata-ahci-platform/description
@@ -124,22 +124,6 @@ endef
$(eval $(call KernelPackage,ata-marvell-sata))
-define KernelPackage/ata-mvebu-ahci
- TITLE:=Marvell EBU AHCI support
- DEPENDS:=@TARGET_mvebu +kmod-ata-ahci-platform
- KCONFIG:=CONFIG_AHCI_MVEBU
- FILES:=$(LINUX_DIR)/drivers/ata/ahci_mvebu.ko
- AUTOLOAD:=$(call AutoLoad,41,ahci_mvebu,1)
- $(call AddDepends/ata)
-endef
-
-define KernelPackage/ata-mvebu-ahci/description
- AHCI support for Marvell EBU SoCs
-endef
-
-$(eval $(call KernelPackage,ata-mvebu-ahci))
-
-
define KernelPackage/ata-nvidia-sata
TITLE:=Nvidia Serial ATA support
KCONFIG:=CONFIG_SATA_NV