aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/block.mk
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2015-08-21 09:48:05 +0000
committerZoltan HERPAI <wigyori@uid0.hu>2015-08-21 09:48:05 +0000
commitd5df4f1e5e61330395434eed6c15bfe19507bb33 (patch)
tree3e79742f7c660e1b10ea32f8e916af33fd6441d3 /package/kernel/linux/modules/block.mk
parentb99e2a80a88c901f6086cea0a84bc650ec284eef (diff)
downloadmaster-187ad058-d5df4f1e5e61330395434eed6c15bfe19507bb33.tar.gz
master-187ad058-d5df4f1e5e61330395434eed6c15bfe19507bb33.tar.bz2
master-187ad058-d5df4f1e5e61330395434eed6c15bfe19507bb33.zip
Newer kernels make use of libahci in ahci-platform, ie. also on non-PCI
platforms. As there is no single config symbol deciding whether libahci.ko is being built or not it seems the most sensitive thing to package it in kmod-ata-core. Signed-off-by: Daniel Golle <daniel@makrotopia.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46701 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/block.mk')
-rw-r--r--package/kernel/linux/modules/block.mk12
1 files changed, 7 insertions, 5 deletions
diff --git a/package/kernel/linux/modules/block.mk b/package/kernel/linux/modules/block.mk
index ccbb0805c8..32e6165cfc 100644
--- a/package/kernel/linux/modules/block.mk
+++ b/package/kernel/linux/modules/block.mk
@@ -25,9 +25,12 @@ $(eval $(call KernelPackage,aoe))
define KernelPackage/ata-core
SUBMENU:=$(BLOCK_MENU)
TITLE:=Serial and Parallel ATA support
- DEPENDS:=@PCI_SUPPORT +kmod-scsi-core
+ DEPENDS:=@PCI_SUPPORT||TARGET_sunxi +kmod-scsi-core
KCONFIG:=CONFIG_ATA
FILES:=$(LINUX_DIR)/drivers/ata/libata.ko
+ifneq ($(wildcard $(LINUX_DIR)/drivers/ata/libahci.ko),)
+ FILES+=$(LINUX_DIR)/drivers/ata/libahci.ko
+endif
endef
$(eval $(call KernelPackage,ata-core))
@@ -43,8 +46,7 @@ define KernelPackage/ata-ahci
TITLE:=AHCI Serial ATA support
KCONFIG:=CONFIG_SATA_AHCI
FILES:= \
- $(LINUX_DIR)/drivers/ata/ahci.ko \
- $(LINUX_DIR)/drivers/ata/libahci.ko
+ $(LINUX_DIR)/drivers/ata/ahci.ko
AUTOLOAD:=$(call AutoLoad,41,libahci ahci,1)
$(call AddDepends/ata)
endef
@@ -62,8 +64,8 @@ define KernelPackage/ata-ahci-platform
FILES:= \
$(LINUX_DIR)/drivers/ata/ahci_platform.ko \
$(LINUX_DIR)/drivers/ata/libahci_platform.ko
- AUTOLOAD:=$(call AutoLoad,40,libahci_platform ahci_platform,1)
- $(call AddDepends/ata,@TARGET_ipq806x||TARGET_mvebu +kmod-ata-ahci)
+ AUTOLOAD:=$(call AutoLoad,40,libahci libahci_platform ahci_platform,1)
+ $(call AddDepends/ata,@TARGET_ipq806x||TARGET_mvebu||TARGET_sunxi)
endef
define KernelPackage/ata-ahci-platform/description