aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/block.mk
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-07-04 12:52:57 +0000
committerJonas Gorski <jogo@openwrt.org>2015-07-04 12:52:57 +0000
commita539c707ff910c83f29e1c3a7a81b86f24790eec (patch)
tree47e20f942f13d74d316edd8fe5f7d39c6fa1a112 /package/kernel/linux/modules/block.mk
parent1100b0c3971772f11319729497a17e02e0595d83 (diff)
downloadmaster-187ad058-a539c707ff910c83f29e1c3a7a81b86f24790eec.tar.gz
master-187ad058-a539c707ff910c83f29e1c3a7a81b86f24790eec.tar.bz2
master-187ad058-a539c707ff910c83f29e1c3a7a81b86f24790eec.zip
kernel: kmod-scsi-core: fix load on install
sd_mod depends on scsi_mod, but due to it being an AutoLoad and not AutoProbe module, it was not loading when installing the package, causing unknown symbol errors for sd_mod and anything depending on it. Closes #14927, #18293, #19351. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46176 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/block.mk')
-rw-r--r--package/kernel/linux/modules/block.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/block.mk b/package/kernel/linux/modules/block.mk
index afa0cd3349..ccbb0805c8 100644
--- a/package/kernel/linux/modules/block.mk
+++ b/package/kernel/linux/modules/block.mk
@@ -616,9 +616,9 @@ define KernelPackage/scsi-core
CONFIG_SCSI \
CONFIG_BLK_DEV_SD
FILES:= \
- $(if $(findstring y,$(CONFIG_SCSI)),,$(LINUX_DIR)/drivers/scsi/scsi_mod.ko) \
+ $(LINUX_DIR)/drivers/scsi/scsi_mod.ko \
$(LINUX_DIR)/drivers/scsi/sd_mod.ko
- AUTOLOAD:=$(call AutoLoad,40,sd_mod,1)
+ AUTOLOAD:=$(call AutoLoad,40,scsi_mod sd_mod,1)
endef
$(eval $(call KernelPackage,scsi-core))