aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/block.mk
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-07-18 13:08:33 +0000
committerJonas Gorski <jogo@openwrt.org>2013-07-18 13:08:33 +0000
commit0dab4848f48826a9604dd96edc8957c639d162af (patch)
tree099822c67220290d945ec92a6de1de5fb7378fba /package/kernel/linux/modules/block.mk
parentbab75297b4f291e857e9b965cd7537d6f08c788d (diff)
downloadmaster-187ad058-0dab4848f48826a9604dd96edc8957c639d162af.tar.gz
master-187ad058-0dab4848f48826a9604dd96edc8957c639d162af.tar.bz2
master-187ad058-0dab4848f48826a9604dd96edc8957c639d162af.zip
kernel: move xor into its own package
xor.ko is needed by btrfs in 3.10+, so split it out into its own package. Make it hidden as it does not provide any functionality on its own. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37395 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/block.mk')
-rw-r--r--package/kernel/linux/modules/block.mk8
1 files changed, 3 insertions, 5 deletions
diff --git a/package/kernel/linux/modules/block.mk b/package/kernel/linux/modules/block.mk
index e522276162..b688084637 100644
--- a/package/kernel/linux/modules/block.mk
+++ b/package/kernel/linux/modules/block.mk
@@ -306,10 +306,9 @@ $(eval $(call KernelPackage,md-raid10))
define KernelPackage/md-raid456
-$(call KernelPackage/md/Depends,+kmod-lib-raid6)
+$(call KernelPackage/md/Depends,+kmod-lib-raid6 +kmod-lib-xor)
TITLE:=RAID Level 456 Driver
KCONFIG:= \
- CONFIG_XOR_BLOCKS \
CONFIG_ASYNC_CORE \
CONFIG_ASYNC_MEMCPY \
CONFIG_ASYNC_XOR \
@@ -319,14 +318,13 @@ $(call KernelPackage/md/Depends,+kmod-lib-raid6)
CONFIG_MD_RAID456 \
CONFIG_MULTICORE_RAID456=n
FILES:= \
- $(LINUX_DIR)/crypto/xor.ko \
$(LINUX_DIR)/crypto/async_tx/async_tx.ko \
$(LINUX_DIR)/crypto/async_tx/async_memcpy.ko \
$(LINUX_DIR)/crypto/async_tx/async_xor.ko \
$(LINUX_DIR)/crypto/async_tx/async_pq.ko \
$(LINUX_DIR)/crypto/async_tx/async_raid6_recov.ko \
- $(LINUX_DIR)/drivers/md/raid456.ko \
- AUTOLOAD:=$(call AutoLoad,28, xor async_tx async_memcpy async_xor async_pq async_raid6_recov raid456)
+ $(LINUX_DIR)/drivers/md/raid456.ko
+ AUTOLOAD:=$(call AutoLoad,28, async_tx async_memcpy async_xor async_pq async_raid6_recov raid456)
endef
define KernelPackage/md-raid456/description