aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/block.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-02-24 12:00:16 +0000
committerJohn Crispin <blogic@openwrt.org>2015-02-24 12:00:16 +0000
commit0491f6fe76d573a5ecd2b705f0739ba6ab6c23d4 (patch)
treea99ced90252212cff95eab5271fb218a6a1c3764 /package/kernel/linux/modules/block.mk
parent9ef5d850549c692cbbf9ef989bb24c520c46ec8d (diff)
downloadmaster-187ad058-0491f6fe76d573a5ecd2b705f0739ba6ab6c23d4.tar.gz
master-187ad058-0491f6fe76d573a5ecd2b705f0739ba6ab6c23d4.tar.bz2
master-187ad058-0491f6fe76d573a5ecd2b705f0739ba6ab6c23d4.zip
modules: add ahci-platform
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44524 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/block.mk')
-rw-r--r--package/kernel/linux/modules/block.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/block.mk b/package/kernel/linux/modules/block.mk
index 20588ac276..159155e049 100644
--- a/package/kernel/linux/modules/block.mk
+++ b/package/kernel/linux/modules/block.mk
@@ -56,6 +56,23 @@ endef
$(eval $(call KernelPackage,ata-ahci))
+define KernelPackage/ata-ahci-platform
+ TITLE:=AHCI Serial ATA Platform support
+ KCONFIG:=CONFIG_SATA_AHCI_PLATFORM
+ FILES:= \
+ $(LINUX_DIR)/drivers/ata/ahci_platform.ko \
+ $(LINUX_DIR)/drivers/ata/libahci_platform.ko
+ AUTOLOAD:=$(call AutoLoad,40,libahci_platform ahci_platform,1)
+ $(call AddDepends/ata,+kmod-ata-ahci)
+endef
+
+define KernelPackage/ata-ahci-platform/description
+ Platform support for AHCI Serial ATA controllers
+endef
+
+$(eval $(call KernelPackage,ata-ahci-platform))
+
+
define KernelPackage/ata-artop
TITLE:=ARTOP 6210/6260 PATA support
KCONFIG:=CONFIG_PATA_ARTOP