aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-07-18 10:47:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-07-18 10:47:00 +0000
commit0cc7b30e786eacb44c650c170b092f408f4b5906 (patch)
treebfa64c8fae501a3159dc11822d2289449df8b2a1 /package/kernel/linux/Makefile
parentb476b188506664176b010366e05131156ab02f66 (diff)
downloadmaster-187ad058-0cc7b30e786eacb44c650c170b092f408f4b5906.tar.gz
master-187ad058-0cc7b30e786eacb44c650c170b092f408f4b5906.tar.bz2
master-187ad058-0cc7b30e786eacb44c650c170b092f408f4b5906.zip
build: add kernel modules to package provides info (along with shared libs)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37385 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/Makefile')
-rw-r--r--package/kernel/linux/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/kernel/linux/Makefile b/package/kernel/linux/Makefile
index d44b5a7767..4ca442f2a5 100644
--- a/package/kernel/linux/Makefile
+++ b/package/kernel/linux/Makefile
@@ -46,6 +46,10 @@ define Package/kernel/install
# nothing to do
endef
+define Package/kernel/extra_provides
+ sed -e 's,.*/,,' $(LINUX_DIR)/modules.builtin;
+endef
+
$(eval $(if $(DUMP),,$(call BuildPackage,kernel)))
include $(sort $(wildcard ./modules/*.mk))