aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/lantiq
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-05-06 17:26:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-05-06 17:26:32 +0000
commit958bcdacea75590c214aa53064bd5f3abb589a00 (patch)
tree8294c98823c8bb486198f8a31e8e45679dafcb6d /package/kernel/lantiq
parent841e3b0e5990118d0e2f9912de629f8c8b1f7ef3 (diff)
downloadmaster-187ad058-958bcdacea75590c214aa53064bd5f3abb589a00.tar.gz
master-187ad058-958bcdacea75590c214aa53064bd5f3abb589a00.tar.bz2
master-187ad058-958bcdacea75590c214aa53064bd5f3abb589a00.zip
ltq-vdsl: force shell to bash to avoid compile errors
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40713 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/lantiq')
-rw-r--r--package/kernel/lantiq/ltq-vdsl/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/kernel/lantiq/ltq-vdsl/Makefile b/package/kernel/lantiq/ltq-vdsl/Makefile
index 0901721b90..d14d4bc955 100644
--- a/package/kernel/lantiq/ltq-vdsl/Makefile
+++ b/package/kernel/lantiq/ltq-vdsl/Makefile
@@ -40,6 +40,9 @@ endef
EXTRA_CFLAGS = -fno-pic -mno-abicalls -mlong-calls -G 0
+MAKE_FLAGS += \
+ SHELL="$(BASH)"
+
CONFIGURE_ARGS += --enable-kernel-include="$(LINUX_DIR)/include" \
--with-max-device="1" \
--with-lines-per-device="1" \