aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/lantiq
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2016-02-25 21:59:56 +0000
committerHauke Mehrtens <hauke@openwrt.org>2016-02-25 21:59:56 +0000
commit67da2b988d92a0df869b22e958d0f33b06ff927a (patch)
treed7474ddc9839932a5a5793c0f7fa0fb03b2da340 /package/kernel/lantiq
parentc0922eda6460ced9bab4f7a608516acdae84914d (diff)
downloadmaster-187ad058-67da2b988d92a0df869b22e958d0f33b06ff927a.tar.gz
master-187ad058-67da2b988d92a0df869b22e958d0f33b06ff927a.tar.bz2
master-187ad058-67da2b988d92a0df869b22e958d0f33b06ff927a.zip
ltq-vdsl-mei: activate format security checks
This activates the format warnings in this package and that makes it possible to activate format-security checks. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48785 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/lantiq')
-rw-r--r--package/kernel/lantiq/ltq-vdsl-mei/Makefile1
-rw-r--r--package/kernel/lantiq/ltq-vdsl-mei/patches/010-warnings.patch11
2 files changed, 11 insertions, 1 deletions
diff --git a/package/kernel/lantiq/ltq-vdsl-mei/Makefile b/package/kernel/lantiq/ltq-vdsl-mei/Makefile
index 64a7cf3026..e0617aeb57 100644
--- a/package/kernel/lantiq/ltq-vdsl-mei/Makefile
+++ b/package/kernel/lantiq/ltq-vdsl-mei/Makefile
@@ -19,7 +19,6 @@ PKG_MD5SUM:=78bf61dbc3421123c6716b874a930759
PKG_FIXUP:=autoreconf
PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
PKG_USE_MIPS16:=0
-PKG_CHECK_FORMAT_SECURITY:=0
include $(INCLUDE_DIR)/package.mk
diff --git a/package/kernel/lantiq/ltq-vdsl-mei/patches/010-warnings.patch b/package/kernel/lantiq/ltq-vdsl-mei/patches/010-warnings.patch
index a3c7dfe26d..04fa36b15e 100644
--- a/package/kernel/lantiq/ltq-vdsl-mei/patches/010-warnings.patch
+++ b/package/kernel/lantiq/ltq-vdsl-mei/patches/010-warnings.patch
@@ -24,3 +24,14 @@
if (pDynNfc->pRecvDataCntrl[pDynNfc->rdIdxRd].bufCtrl != MEI_RECV_BUF_CTRL_FREE) /* buffer in use */
{
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -201,7 +201,7 @@ else
+
+ drv_mei_cpe_common_cflags = \
+ $(AM_CFLAGS) -D__KERNEL__ -DLINUX -D__linux__ -DMODULE -DEXPORT_SYMTAB \
+- -pipe -Wno-format -Wimplicit -Wunused -Wuninitialized -Wsign-compare -Wstrict-aliasing
++ -pipe -Wall -Wimplicit -Wunused -Wuninitialized -Wstrict-aliasing
+
+ endif
+