aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/lantiq/ltq-ifxos/patches
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-09-14 20:09:22 +0000
committerJohn Crispin <blogic@openwrt.org>2015-09-14 20:09:22 +0000
commitd6661dd0e43444c265b08b3d92c2044c2c2a8358 (patch)
treeaf6ba8c17f968031a26c7595144e1449351fd9c0 /package/kernel/lantiq/ltq-ifxos/patches
parent62b8a84312803f029a4056cbfbb2090bc42110c2 (diff)
downloadmaster-187ad058-d6661dd0e43444c265b08b3d92c2044c2c2a8358.tar.gz
master-187ad058-d6661dd0e43444c265b08b3d92c2044c2c2a8358.tar.bz2
master-187ad058-d6661dd0e43444c265b08b3d92c2044c2c2a8358.zip
lantiq: Update to the latest DSL driver / application versions
Thanks to Sylwester Petela for testing my patch (successfully on an ADSL connection) and for pointing out some configuration mistakes. Others (including me) have also successfully tested this extensively on VDSL connections. Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46920 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/lantiq/ltq-ifxos/patches')
-rw-r--r--package/kernel/lantiq/ltq-ifxos/patches/100-compat.patch27
1 files changed, 7 insertions, 20 deletions
diff --git a/package/kernel/lantiq/ltq-ifxos/patches/100-compat.patch b/package/kernel/lantiq/ltq-ifxos/patches/100-compat.patch
index db2dd8bc5e..dcd260ef3f 100644
--- a/package/kernel/lantiq/ltq-ifxos/patches/100-compat.patch
+++ b/package/kernel/lantiq/ltq-ifxos/patches/100-compat.patch
@@ -1,27 +1,14 @@
---- a/configure.in
-+++ b/configure.in
-@@ -64,7 +64,7 @@ dnl Set kernel build path
- AC_ARG_ENABLE(kernelbuild,
- AS_HELP_STRING(--enable-kernelbuild=x,Set the target kernel build path (only for kernel 2.6.x)),
- [
-- if test -e $enableval/include/linux/autoconf.h; then
-+ if test -e $enableval/include/linux/autoconf.h -o -e $enableval/include/generated/autoconf.h; then
- AC_SUBST([KERNEL_BUILD_PATH],[$enableval])
- else
- AC_MSG_ERROR([The kernel build directory is not valid or not configured!])
--- a/src/linux/ifxos_linux_thread_drv.c
+++ b/src/linux/ifxos_linux_thread_drv.c
-@@ -34,8 +34,8 @@
- #include <linux/sched.h>
- #include <linux/version.h>
- #include <linux/completion.h>
--#include <linux/smp_lock.h>
+@@ -38,6 +38,7 @@
+ #include <linux/smp_lock.h>
+ #endif
#include <linux/signal.h>
+#include <linux/kthread.h>
#include "ifx_types.h"
-@@ -68,10 +68,6 @@
+@@ -70,10 +71,6 @@
#if ( defined(IFXOS_HAVE_THREAD) && (IFXOS_HAVE_THREAD == 1) )
@@ -32,7 +19,7 @@
/* ============================================================================
IFX Linux adaptation - Kernel Thread handling
========================================================================= */
-@@ -96,9 +92,9 @@ IFXOS_STATIC IFX_int32_t IFXOS_KernelThr
+@@ -98,9 +95,9 @@ IFXOS_STATIC IFX_int32_t IFXOS_KernelThr
- IFX_SUCCESS on success
- IFX_ERROR on error
*/
@@ -44,7 +31,7 @@
IFX_int32_t retVal = IFX_ERROR;
#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,0))
struct task_struct *kthread = current;
-@@ -139,7 +135,7 @@ IFXOS_STATIC IFX_int32_t IFXOS_KernelThr
+@@ -141,7 +138,7 @@ IFXOS_STATIC IFX_int32_t IFXOS_KernelThr
/* let others run */
unlock_kernel();
#else
@@ -53,7 +40,7 @@
/* Enable signals in Kernel >= 2.6 */
allow_signal(SIGKILL);
-@@ -218,9 +214,7 @@ IFX_int32_t IFXOS_ThreadInit(
+@@ -221,9 +218,7 @@ IFX_int32_t IFXOS_ThreadInit(
init_completion(&pThrCntrl->thrCompletion);
/* start kernel thread via the wrapper function */