aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/hostap-driver
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-09-17 21:45:17 +0000
committerJohn Crispin <blogic@openwrt.org>2013-09-17 21:45:17 +0000
commit751f92881546b07452e922ad15be9d446f23f592 (patch)
tree2659076169733540dabefd531b086be6ce69f345 /package/kernel/hostap-driver
parenta1d883cc85daebe3acdcbb5e61183db57040d02a (diff)
downloadmaster-187ad058-751f92881546b07452e922ad15be9d446f23f592.tar.gz
master-187ad058-751f92881546b07452e922ad15be9d446f23f592.tar.bz2
master-187ad058-751f92881546b07452e922ad15be9d446f23f592.zip
kernel: make most modules use AutoProbe
now that we have modprobe we can set more than half of the modules to AutoProbe Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38021 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/hostap-driver')
-rw-r--r--package/kernel/hostap-driver/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/kernel/hostap-driver/Makefile b/package/kernel/hostap-driver/Makefile
index d08fd9c0a5..6a95c1e1d8 100644
--- a/package/kernel/hostap-driver/Makefile
+++ b/package/kernel/hostap-driver/Makefile
@@ -37,7 +37,7 @@ $(call KernelPackage/hostap/Default)
DEPENDS:=@PCI_SUPPORT||PCMCIA_SUPPORT +kmod-lib80211 +wireless-tools
KCONFIG:=CONFIG_HOSTAP CONFIG_HOSTAP_FIRMWARE=y CONFIG_HOSTAP_FIRMWARE_NVRAM=y
FILES:=$(LINUX_DIR)/drivers/net/wireless/hostap/hostap.ko
- AUTOLOAD:=$(call AutoLoad,60,hostap)
+ AUTOLOAD:=$(call AutoProbe,hostap)
endef
define KernelPackage/hostap/description
@@ -54,7 +54,7 @@ $(call KernelPackage/hostap/Default)
DEPENDS:=@PCMCIA_SUPPORT +kmod-hostap +kmod-pcmcia-core
KCONFIG:=CONFIG_HOSTAP_CS
FILES:=$(LINUX_DIR)/drivers/net/wireless/hostap/hostap_cs.ko
- AUTOLOAD:=$(call AutoLoad,60,hostap_cs)
+ AUTOLOAD:=$(call AutoProbe,hostap_cs)
endef
define KernelPackage/hostap-cs/description
@@ -69,7 +69,7 @@ $(call KernelPackage/hostap/Default)
DEPENDS:=@PCI_SUPPORT +kmod-hostap
KCONFIG:=CONFIG_HOSTAP_PCI
FILES:=$(LINUX_DIR)/drivers/net/wireless/hostap/hostap_pci.ko
- AUTOLOAD:=$(call AutoLoad,60,hostap_pci)
+ AUTOLOAD:=$(call AutoProbe,hostap_pci)
endef
define KernelPackage/hostap-pci/description
@@ -84,7 +84,7 @@ $(call KernelPackage/hostap/Default)
DEPENDS:=@PCI_SUPPORT +kmod-hostap
KCONFIG:=CONFIG_HOSTAP_PLX
FILES:=$(LINUX_DIR)/drivers/net/wireless/hostap/hostap_plx.ko
- AUTOLOAD:=$(call AutoLoad,60,hostap_plx)
+ AUTOLOAD:=$(call AutoProbe,hostap_plx)
endef
define KernelPackage/hostap-plx/description