aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/brcm2708-gpu-fw
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-02-11 10:17:55 +0000
committerJohn Crispin <blogic@openwrt.org>2015-02-11 10:17:55 +0000
commitc291f76d24a4190551a42b7b77a2cfeb3f4d36f9 (patch)
tree8f9211217d7e2cbaa78d10b596d81e646b3b9aad /package/kernel/brcm2708-gpu-fw
parent0e26998162921c65cbfe2814e500c81ca7b50dad (diff)
downloadmaster-187ad058-c291f76d24a4190551a42b7b77a2cfeb3f4d36f9.tar.gz
master-187ad058-c291f76d24a4190551a42b7b77a2cfeb3f4d36f9.tar.bz2
master-187ad058-c291f76d24a4190551a42b7b77a2cfeb3f4d36f9.zip
brcm2708: update to v3.18
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44392 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/brcm2708-gpu-fw')
-rw-r--r--package/kernel/brcm2708-gpu-fw/Makefile24
1 files changed, 9 insertions, 15 deletions
diff --git a/package/kernel/brcm2708-gpu-fw/Makefile b/package/kernel/brcm2708-gpu-fw/Makefile
index 364fd23e0f..e20200207c 100644
--- a/package/kernel/brcm2708-gpu-fw/Makefile
+++ b/package/kernel/brcm2708-gpu-fw/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2012-2014 OpenWrt.org
+# Copyright (C) 2012-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -7,16 +7,15 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
-PKG_NAME:=brcm2708-gpu-fw
-PKG_REV:=e25efc4545d0cef7c49c82e770b3e4ccfc8aba4c
-PKG_VERSION:=20140226
-PKG_RELEASE:=1
+PKG_NAME:=brcm2708-gpu-fw-boot
+PKG_VERSION:=2015-02-07
+PKG_RELEASE:=$(PKG_SOURCE_VERSION)
+PKG_MD5SUM:=f198d5466ec412424f3ca77703f29d15
-PKG_SOURCE:=$(PKG_REV).tar.gz
-PKG_SOURCE_URL:=https://github.com/Hexxeh/rpi-firmware/archive/
-PKG_MD5SUM:=b1bb6b1063c4f920314274edd39c35e6
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)/rpi-firmware-$(PKG_REV)
+PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources/
+# PKG_SOURCE_SUBDIR:=$(PKG_NAME)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
include $(INCLUDE_DIR)/package.mk
@@ -35,10 +34,5 @@ endef
define Build/Compile
endef
-define Build/InstallDev
- $(INSTALL_DIR) $(BUILD_DIR)/brcm2708-gpu-fw-boot
- $(CP) $(PKG_BUILD_DIR)/* $(BUILD_DIR)/brcm2708-gpu-fw-boot
-endef
-
$(eval $(call BuildPackage,brcm2708-gpu-fw))