aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/acx-mac80211
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-12-11 19:35:36 +0000
committerJonas Gorski <jogo@openwrt.org>2014-12-11 19:35:36 +0000
commite39e2ba511089e859255ac843aabae4560091c77 (patch)
treeba38ecf9d13e57365dbe56ba87a9d98ea021f1bc /package/kernel/acx-mac80211
parent98c1678e8d914286ffe5173f6e687952ca9d616f (diff)
downloadmaster-187ad058-e39e2ba511089e859255ac843aabae4560091c77.tar.gz
master-187ad058-e39e2ba511089e859255ac843aabae4560091c77.tar.bz2
master-187ad058-e39e2ba511089e859255ac843aabae4560091c77.zip
kernel/acx-mac80211: fix autoloading on boot
The kernel build system cannot track dependencies of out-of-tree modules, making the buildsystem fail to load mac80211. Add mac80211 as an explicit load to ensure all required modules are loaded. Fixes #16522. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43631 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/acx-mac80211')
-rw-r--r--package/kernel/acx-mac80211/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/acx-mac80211/Makefile b/package/kernel/acx-mac80211/Makefile
index 16f6f5d06e..dfb73f71b8 100644
--- a/package/kernel/acx-mac80211/Makefile
+++ b/package/kernel/acx-mac80211/Makefile
@@ -32,7 +32,7 @@ define KernelPackage/acx-mac80211
TITLE:=ACX1xx mac80211 driver
DEPENDS:=@(PCI_SUPPORT||TARGET_ar7) @mipsel +kmod-mac80211
FILES:=$(PKG_BUILD_DIR)/acx-mac80211.ko
- AUTOLOAD:=$(call AutoLoad,50,acx-mac80211)
+ AUTOLOAD:=$(call AutoLoad,50,mac80211 acx-mac80211)
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
MENU:=1
endef