aboutsummaryrefslogtreecommitdiffstats
path: root/package/iptables
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-05-31 13:00:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-05-31 13:00:11 +0000
commit24c7f4cd0864361627e692df88f3a1c9e7ee2e79 (patch)
treece904f5e4faf9da3c1b22c1670dfe9c1c54a05c6 /package/iptables
parent58682e173d175d76ad499431676911b650cd4853 (diff)
downloadmaster-187ad058-24c7f4cd0864361627e692df88f3a1c9e7ee2e79.tar.gz
master-187ad058-24c7f4cd0864361627e692df88f3a1c9e7ee2e79.tar.bz2
master-187ad058-24c7f4cd0864361627e692df88f3a1c9e7ee2e79.zip
add missing BuildPackage lines, convert install-dev: to Build/InstallDev
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3857 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/iptables')
-rw-r--r--package/iptables/Makefile34
1 files changed, 16 insertions, 18 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index ae2adcfa08..4c547be998 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -162,6 +162,22 @@ define Build/Compile
DESTDIR="$(PKG_INSTALL_DIR)" \
all install install-devel
endef
+
+
+define Build/InstallDev
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(TARGET_CONFIGURE_OPTS) \
+ CC=$(TARGET_CC) COPT_FLAGS="$(TARGET_CFLAGS)" \
+ KERNEL_DIR=$(LINUX_DIR) PREFIX=/usr \
+ DESTDIR="$(STAGING_DIR)" \
+ install install-devel
+endef
+
+define Build/UninstallDev
+ rm -rf $(STAGING_DIR)/usr/include/libipq.h
+ rm -rf $(STAGING_DIR)/usr/lib/libipq.a
+endef
+
define Package/iptables/install
install -d -m0755 $(1)/etc/config
@@ -223,21 +239,3 @@ $(eval $(call BuildPlugin,iptables-mod-ipsec,$(IPT_IPSEC-m)))
$(eval $(call BuildPlugin,iptables-mod-nat,$(IPT_NAT-m)))
$(eval $(call BuildPlugin,iptables-mod-ulog,$(IPT_ULOG-m)))
$(eval $(call BuildPackage,ip6tables))
-
-
-$(STAGING_DIR)/usr/lib/libipq.a: $(PKG_BUILD_DIR)/.built
- $(MAKE) -C $(PKG_BUILD_DIR) \
- $(TARGET_CONFIGURE_OPTS) \
- CC=$(TARGET_CC) COPT_FLAGS="$(TARGET_CFLAGS)" \
- KERNEL_DIR=$(LINUX_DIR) PREFIX=/usr \
- DESTDIR="$(STAGING_DIR)" \
- install install-devel
-
-install-dev: $(STAGING_DIR)/usr/lib/libipq.a
-uninstall-dev:
- rm -rf $(STAGING_DIR)/usr/include/libipq.h
- rm -rf $(STAGING_DIR)/usr/lib/libipq.a
-
-compile-targets: install-dev
-clean-targets: uninstall-dev
-