aboutsummaryrefslogtreecommitdiffstats
path: root/package/iptables/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-02-24 01:59:32 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-02-24 01:59:32 +0000
commit0a72720a3c14ec4865eaf09e6a36c4e620df3a07 (patch)
tree1a229aaf2e4fb7472d875d3d1521611d71c5e779 /package/iptables/Makefile
parent572fbb89f10cad018caa91503909ef705f930f8c (diff)
downloadmaster-187ad058-0a72720a3c14ec4865eaf09e6a36c4e620df3a07.tar.gz
master-187ad058-0a72720a3c14ec4865eaf09e6a36c4e620df3a07.tar.bz2
master-187ad058-0a72720a3c14ec4865eaf09e6a36c4e620df3a07.zip
[package] iptables: fix a segfault when iptables tries to use modprobe, force it to use insmod
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19827 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/iptables/Makefile')
-rw-r--r--package/iptables/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index 20e4b315ca..68ccc76282 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -254,6 +254,10 @@ TARGET_CPPFLAGS := \
-I$(LINUX_DIR)/arch/$(LINUX_KARCH)/include \
$(TARGET_CPPFLAGS)
+TARGET_CFLAGS := \
+ $(TARGET_CFLAGS) \
+ -DFORCE_MODPROBE_PROGRAM="\\\"/sbin/insmod\\\""
+
CONFIGURE_ARGS += \
--enable-shared \
--enable-devel \