aboutsummaryrefslogtreecommitdiffstats
path: root/package/hotplug2/patches
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-03-26 14:28:25 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-03-26 14:28:25 +0000
commit6189513013a9baeaff1eae4f8e15c8652bf2daf3 (patch)
tree2a1fad76dd45ad929d681521ffbc4df57649d8f5 /package/hotplug2/patches
parent6d0e3baeee2fd456502db54160a4afff2f25d19c (diff)
downloadmaster-187ad058-6189513013a9baeaff1eae4f8e15c8652bf2daf3.tar.gz
master-187ad058-6189513013a9baeaff1eae4f8e15c8652bf2daf3.tar.bz2
master-187ad058-6189513013a9baeaff1eae4f8e15c8652bf2daf3.zip
package/hotplug2: refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20462 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/hotplug2/patches')
-rw-r--r--package/hotplug2/patches/100-env_memleak.patch9
-rw-r--r--package/hotplug2/patches/110-static_worker.patch12
2 files changed, 9 insertions, 12 deletions
diff --git a/package/hotplug2/patches/100-env_memleak.patch b/package/hotplug2/patches/100-env_memleak.patch
index 31f404029e..28a3e2510f 100644
--- a/package/hotplug2/patches/100-env_memleak.patch
+++ b/package/hotplug2/patches/100-env_memleak.patch
@@ -1,7 +1,6 @@
-diff -Naur a/action.c b/action.c
---- a/action.c 2009-11-18 13:15:21.000000000 +0000
-+++ b/action.c 2009-11-18 13:11:19.000000000 +0000
-@@ -31,6 +31,30 @@
+--- a/action.c
++++ b/action.c
+@@ -31,6 +31,30 @@ static void action_dumb(const struct set
}
/**
@@ -32,7 +31,7 @@ diff -Naur a/action.c b/action.c
* Choose what action should be taken according to passed settings.
*
* @1 Hotplug settings
-@@ -41,16 +65,25 @@
+@@ -41,16 +65,25 @@ static void action_dumb(const struct set
*/
void action_perform(struct settings_t *settings, struct uevent_t *event) {
int i;
diff --git a/package/hotplug2/patches/110-static_worker.patch b/package/hotplug2/patches/110-static_worker.patch
index bca4aace7c..3a5181f74d 100644
--- a/package/hotplug2/patches/110-static_worker.patch
+++ b/package/hotplug2/patches/110-static_worker.patch
@@ -1,6 +1,5 @@
-diff -Naur a/common.mak b/common.mak
---- a/common.mak 2009-11-18 13:15:21.000000000 +0000
-+++ b/common.mak 2009-11-18 13:25:18.000000000 +0000
+--- a/common.mak
++++ b/common.mak
@@ -1,7 +1,7 @@
# vim:set sw=8 nosta:
@@ -10,10 +9,9 @@ diff -Naur a/common.mak b/common.mak
CFLAGS=$(COPTS)
FPIC=-fPIC
-diff -Naur a/Makefile b/Makefile
---- a/Makefile 2009-11-18 13:15:21.000000000 +0000
-+++ b/Makefile 2009-11-18 13:25:18.000000000 +0000
-@@ -40,5 +40,6 @@
+--- a/Makefile
++++ b/Makefile
+@@ -40,5 +40,6 @@ ifdef STATIC_WORKER
CFLAGS += -DSTATIC_WORKER=1
else
CFLAGS += $(FPIC)